This page last changed on Dec 15, 2012 by kslate.

I'm curious if anyone is using an HP Touchpad running CyanongenMod's Android port (Android 4)? While it works, I'm a bit surprised at the lack or resolution. This very well may be due to the Android port but has anyone been able to get any type of higher res out of the unit? If so, how? I've tried two different versions including one of the latest with not much luck.

I have a design configured for an iPad and I've tried a custom screen for the Touchpad (which should be able to do 1024x768) but the images show only about 320x200 (or something close to that - very low res). Is there a solution for this that I'm just not looking at or are we simply talking about a limitation of the Touchpad running Openremote?

I use this beta or alpha release for my 800*480 Android: http://multimation.co.uk:8080/controller/AndroidWebConsole.apk

Posted by pz1 at Dec 15, 2012 16:25

Hi Kevin,

There are scaling issues with the current Android app and this is due to display density difference between devices, Android (and iOS also) tries to be clever and it will scale the UI to try and maintain physical size across different display densities and as such it will trick the app and although you may have a display with 1024px x 768px if Android identifies it as having a display density of 2 then the app would think you have a 512px x 384px display.

We're looking at addressing this at the moment; on the iPhone for example with a retina display which has a display of 640px x 960px you still have to create a panel in the designer with a size of 320 x 480 because the display density is 2 (i.e. there are twice as many pixels per inch - how many pixels per inch is 'standard' is a decision made by the implementation - for web browsers it is 96dpi, for Android and iOS it is 160dpi - hence an iPhone screen is 2" x 3" in physical size).

Rich

Posted by kurrazyman at Dec 16, 2012 15:52

I was trying to install OR on the Android Sony Tablet S with a native resolution of 1280x800, and it turned out that I could only use something like 320x500 pixels. (OR client version 2.0.0 Beta2 from Androidshop.) This leaves room for improvements...

Posted by barf at Dec 16, 2012 20:02

Thanks for the input... Kinda looks like the Android side of things is a bit in flux. Wish I had another device (Android) to test things out with.

Posted by kslate at Dec 17, 2012 15:37

I found an Android Beta3 apk at some point. You might have to get it from SVN and build it yourself (http://openremote.svn.sourceforge.net/viewvc/openremote/tags/project/Android_Console/Android_Console_2_0_0_Beta3/)

I can confirm it works on the Touchpad with Android 4 (CM9... not sure which exact version).

I used the iPad resolution in the Designer.

MD

Posted by mdarwin at Dec 17, 2012 16:12

This forum thread has a apk attached to it: http://www.openremote.org/pages/viewpage.action?pageId=21037250
The apk is here: http://www.openremote.org/download/attachments/21037250/OpenRemote-debug.apk?version=1

Maybe you can give it a try.

Posted by mredeker at Dec 18, 2012 08:20

I'm a bit curious and hesitant to try this last .apk file (http://www.openremote.org/download/attachments/21037250/OpenRemote-debug.apk?version=1). Why does an openremote android app need access to contacts/phone list? I would think that it would only need network access...? It caused me not to try/install it.

And for whatever reason, I can't seem to run the web console at all...? (http://multimation.co.uk:8080/controller/AndroidWebConsole.apk uses a form of it?). Even my controller install of openremote won't run it correctly. It runs. I can connect to it. I can configure settings. But I never get any graphics to show up on screen no matter what size I choose or how I configure things. However this is probably best posted as it's own forum topic.

Kevin

Posted by kslate at Dec 20, 2012 20:36

Hi Kevin,

I don't know why the Android Console is set to request all the permissions it does; as you say it only needs network access which is all that is requested in the Android Web Console apk. I will be releasing a more stable version soon and will fix this.

Regarding your Web Console related issues, if you are not using security on your controller and you get stuck at the loading screen then you have the same issue as some other users which I haven't had time to get to the bottom of yet, if you could try connecting to the following controller to see if it works, if it does then could you possibly zip your logs directory and email it to me (richard[at]openremote[dot]org.

http://multimation.co.uk:8080/controller

Regards,

Rich

Posted by kurrazyman at Dec 20, 2012 22:50

Thanks for the reply... After syncing with this controller (I assume the idea is to reload the local controller .xml files?) I get a Web Console error. Panel XML not found. I looked on my controller and the panel.xml file is there (owned by root if that matters. In fact most of the webapps/controller files are owned by root. I guess the question is should they be?) I will send the log files soon (if you are still interested in looking at them?).

Posted by kslate at Dec 21, 2012 20:56

http://openremote.org/display/forums/New+Android+Console+2.1.0+Beta%21

Posted by kurrazyman at Jan 30, 2013 21:15

Do we still need to using a custom APK? I just installed openremote on my touchpad en density is to low (grainy text and buttons)

Posted by dijkdj at Jan 28, 2015 16:09
Document generated by Confluence on Jun 05, 2016 09:30