This page last changed on Apr 17, 2013 by juha.

Hello,

I'm having a problem when I try to access the Designer through the OpenRemote Controller ( http://localhost:8080/controller/ )
[NOTE: I have follow carefully the installation of de controller in my RPi and everything is ok]
I've created an account in the designer and I've activated it too, but when I use my credentials here ( http://localhost:8080/controller/) I can't access and I get this message on my web browser (Safari):
"Authentication failed, please check your username and password"

Reading the console, this is the message displayed:
"ERROR [HTTP-Thread-3]: Synchronizing controller with online account failed : Authentication failed, please check your username and password.
org.openremote.controller.exception.ConnectionException: Authentication failed, please check your username and password."

On the other hand, If I try to access directly using this address ( http://composer.openremote.org/demo/login.jsp ), I have no problem accessing and everything works fine.

Any suggestion or advice are welcome!
Thanx in advance,

alucien


Make sure you're using the correct case on your username. The login name on the designer is case insensitive, whereas it is case sensitive when syncing on the controller.

Also make sure the controller has the correct designer defined in its properties.

Posted by ebariaux at Mar 22, 2013 15:45

Hello Eric,

thank you very much for your help.

I've checked several times the username (just the user "alucien" or the complete email address and it's password). I even restore the password and set a new one but without any luck.
Also I've created a new user/passwd with other email account but it didn't work too.

I don't know how to check this issue that you comment: "Also make sure the controller has the correct designer defined in its properties."

On which/where file I have to verify this?

thanks in advance!!

Attached I have included two images:
1) a capture of my OpenRemote Controller screen (My controller is installed onto a Raspberrypi Raspbian) I've also install both, OpenRemote-Controller-2.0.1 and OpenRemote-Controller-2.0.2 with the same result.
2) a capture of the designer login screen on what I can successfully access.

Posted by alucien at Mar 22, 2013 16:56

Hi all!,

finally I've got the SOLUTION!

For everyone with the same problems, there's a simple solution.

1) Enter into the designer web ( http://composer.openremote.org/demo/login.jsp ) with your user/pass
2) Click into the "UI Designer" and create a "new panel" (don't worry if you are not using it later")
3) Click on "save" and "export as a zip"
4) With your controller launched, go to: ( http://localhost:8080/controller/ ) and enter now your user/pass

Now it should work!!! It works for me.
It seems just like if the Designer need something configured on it in order to initialize the user (It's just a supposition).

Regard!

Posted by alucien at Mar 24, 2013 20:01

Thanks for reporting, this should be fixed in the next version.

Posted by admin at Mar 27, 2013 06:31

Works like a charm. Had same Problem and your Approach sorted it. Thanks Antonio!!

Posted by brassalui at Dec 02, 2013 17:59

Thank you very much

I had the same problem and now it works ..... Great

Posted by jonny1970 at Dec 11, 2013 21:23

Brilliant - worked for me too!
Thanks

Posted by dgallimore at Apr 30, 2014 08:43

That also worked for me... I didn't see it mentioned but I'm using a Raspberry PI for my controller with a Z-Wave USB dongle. Figured I'd mention it in case it's a bug with that setup.

Posted by ckeeran at May 15, 2014 16:30

Thank you, Antonio! Worked for me.

Posted by butchalline at Jul 20, 2014 00:02

This is still an issue.

Antonio's solution worked for me too - many thanks - but it's a bit off-putting when you're a newbie to find you have to dig in the forums just to get the thing to work in the first place.

It's also now 17 months after "this should be fixed in the next version"

Posted by simonb at Sep 11, 2014 09:27

and it is not yet fixed on jan 26 2015 and this package is a pain in the R$%#%# to install

Posted by zonegrise at Jan 26, 2015 21:52

Jun 13, 2015
Bug still exists on 2.1.0
Also, don't forget to hit the little save button after creating your panel (floppy disk icon in top left corner group of icons). I didn't see that, just created the panel without saving and still couldn't get it to sync. As soon as I saved, it worked.

Posted by mryauch at Jun 13, 2015 22:07

Ding! Ding! Give that man a prize. That worked. My QNAP TVS-671 can now login to openremote using the composer username & password credentials.

Now, I don't know what I'm doing yet, but at least it's logged in!

Posted by wkearney99 at Aug 10, 2015 18:53
Document generated by Confluence on Jun 05, 2016 09:29