This page last changed on Oct 03, 2013 by nbewhm4.

I've followed the denon help and created a simple remote, and have zipped and downloaded the code. In a browser, when I go to http://localhost:8080/webconsole/#main I see my remote, but when I click the buttons, the denon does absolutely nothing. I've edited the denonAVRSerial.properties file, and set COM2 as the port (I've tried COM1 and COM2 but it makes no difference!) and restarted the OpenRemote. Have I missed a step? Is there an RS232 debugger so I can see if anything is even being sent to the denon box ?
Thanks in advance ! I'm running on Windows xp, the denon model is 2310CI.

DenonAVRSerialCommand is logging sent messages on the info level. You need to make sure that you capture this logging.

Edit webapps/controller/WEB-INF/classes/log4j.properties to add the following line.

log4j.logger.org.openremote.controller.protocol.denonavrserial.DenonAVRSerialCommand = ALL, console, file
  • 'org.openremote.controller.protocol.denonavrserial' is the log catagory created by the DenonAVRSerial logger
  • ALL is the log level (everything)
  • console, file is your appenders (console, which corresponds to catalina.log, and file which is controller.log)
Posted by toesterdahl at Oct 05, 2013 06:37

I tried what was suggested, now (after some code corrections) in the main console & log files I get:

Read: Not implemented, return an empty message

I also see:
INFO 2013-10-07 09:50:42,062 : CommPortIdentifiers :gnu.io.CommPortEnumerator@1fcf790
INFO 2013-10-07 09:50:42,062 : CommPortIdentfier: gnu.io.CommPortIdentifier@e14d81
INFO 2013-10-07 09:50:42,078 : CommPortIdentfier: gnu.io.CommPortIdentifier@1a7789c
INFO 2013-10-07 09:50:42,094 : CommPortIdentfier: gnu.io.CommPortIdentifier@1df5f21
INFO 2013-10-07 09:50:42,219 : CommPortIdentifiers :gnu.io.CommPortEnumerator@158689a
INFO 2013-10-07 09:50:42,234 : CommPortIdentfier: gnu.io.CommPortIdentifier@e14d81
INFO 2013-10-07 09:50:42,234 : CommPortIdentfier: gnu.io.CommPortIdentifier@1a7789c
INFO 2013-10-07 09:50:42,250 : CommPortIdentfier: gnu.io.CommPortIdentifier@1df5f21

And when I slide the volume to zero:
INFO 2013-10-07 09:52:24,973 : CommPortIdentifiers :gnu.io.CommPortEnumerator@11a5fd0
INFO 2013-10-07 09:52:24,973 : CommPortIdentfier: gnu.io.CommPortIdentifier@e14d81
INFO 2013-10-07 09:52:24,973 : CommPortIdentfier: gnu.io.CommPortIdentifier@1a7789c
INFO 2013-10-07 09:52:24,973 : CommPortIdentfier: gnu.io.CommPortIdentifier@1df5f21
INFO 2013-10-07 09:52:24,973 : Command: MV0 DataBytes: 110, 117, 108, 108, 13

Why is null and cr sent to the Denon (110 = n, 117 = u, 108 = l, 13 = carriage return ?

Anyone any ideas as to what I have missed, or is it looking like the Denon 2310CI is not compatible/responding ?

I bought a new cable, this time USB to serial (in case the cable was faulty). Now the power on and standby work

Unfortunately, the volume slider is still sending null - any thoughts ?

This thread has the details of the fixes needed...... http://openremote.org/pages/viewpage.action?pageId=22877755&focusedCommentId=22877812#comment-22877812

Posted by nbewhm4 at Oct 06, 2013 02:21
Document generated by Confluence on Jun 05, 2016 09:40