This page last changed on Dec 15, 2013 by somersmaarten.

Hi,

I am trying to install Raz-OR. So far so good with the install of openremote and the Razzberry.

I am stuck on "Configure Razberry automation engine". I'm supposed to ADD openremote.js to the config.json file but I can't find the code listed below.

"customCodeFiles": [ "custom.js" ]

I've been looking around for a while now but can't find the solution.

My Razzberry is a 1.4.1. Am I going to have full functionality with openremote or not? The tutorial still says that I will not...

Thanks for the help.

I run 1.4.1 with this config.json: http://www.openremote.org/display/forums/Z-Wave+control+with+Razberry?focusedCommentId=22879324#comment-22879324

So for the time being that would work. I understood from Zwave.me that they intend to bundle RaZ-OR (or a further development of it) with a following release.

Hope this config.json works for you

Posted by pz1 at Dec 15, 2013 14:04

Ok Perfect, thanks for that.

I'v been searching for the next solution then.

I use following url for a button in Openremote -> it works. (Also works in browser) http://192.168.7.122:8083/ZWaveAPI/Run/ devices[4].SwitchBinary.Set(0) http://192.168.7.122:8083/ZWaveAPI/Run/ devices[4].SwitchBinary.Set(255)

When I try to use the shortversion from your openremote.js for a button i have no reaction. Seems to me that the openremote.js file is not used by my openremote configuration.

http://192.168.7.122:8083/JS/Run/SwitchBinaryOn(4,0) not working http://192.168.7.122:8083/JS/Run/SwitchBinaryOff(4,0) not working

I'm not using a real switch device but one of those powerplugs to put between the plug and a lamp.

Getting a status does not work either.

Any advice...
Thanks

Posted by somersmaarten at Dec 15, 2013 17:24

For me http://raspberry:8083/JS/Run/SwitchBinaryOn(4,0) works as expected. By sheer coincidence Device 4 in my installation is a DueWi Plugin switch.

Did you reboot your Pi after changing the contents of config.json?

Posted by pz1 at Dec 15, 2013 17:35

Yes, already did a reboot. I'll try again and search the forum. Thanks.

Posted by somersmaarten at Dec 15, 2013 18:03

I deleted the config.json and made it again, after reboot it is working. Only the SwitchBinaryStatus(4,0) still doesn't work.
Thanks

Posted by somersmaarten at Dec 15, 2013 22:09

Aha!

SwitchBinaryStatus(4,0) did not work in Openremote because I put "on | off" instead of "on|off" as the regular expression.

Nice, switches all work. Tomorrow I'll try to put timers on them.

Good night!

Posted by somersmaarten at Dec 16, 2013 00:52
Document generated by Confluence on Jun 05, 2016 09:40