This page last changed on Feb 23, 2016 by jever1966.

Hi

Is there a way to install Openremote Pro 1.4.0 on Synology DS216+ ??

I have installed JAVA version 1.8.0_73-0037 and the prepackaged Openremote version available at http://pcloadletter.co.uk/2011/10/25/openremote-package-for-synology/

For test, I have updated the controller to free version OpenRemote-Controller-2.1.1 and it is working fine, but when I update to OpenRemote-Controller-Pro1.4.0

I get the following error, when I try to sync the PRO controller: an attempt was made to access service context before it was initialized

I am using port 18581

BR
Jesper

1. Update: It is the same problem with the new version Pro 1.4.1 Is there a way to download version Pro 1.3.0
It looks like version Pro 1.3.0 is working http://openremote.wiki-neon.adaptavist.com/pages/viewpage.action?pageId=23602594&focusedCommentId=23602619

PS: I have used this guide for update:

No problem at all. Below I list the steps I take to upgrade the controller. I am running DSM 4.3 on a DS1812 model and OR snapshot 2.1.0_FM_SNAPSHOT-2013-07-18 at the minute, but I have used this method on many combinations of DSM and OR versions and it generally just works. This is not that difficult, but if you completely hose your install, you can simply remove OR in the Synology Package Center and then re-install it, and all will be repaired..

1. Install Patters package at http://pcloadletter.co.uk/2011/10/25/openremote-package-for-synology/
2. Once this is done, this is your baseline point. Even if the next steps don't work for you, simply go to Synology Package Center, un-install OR and then re-install it. Only takes about a minute to do this. This will return you to the basic patters package, which works fine for most cases.
3. Download whatever version of OR you want to use from here: http://sourceforge.net/projects/openremote/files/For%20Developers/OpenRemote%202.1%20%28Developer%20Releases%29/
Extract the zip to a folder on your NAS. In my example I stored it in

/volume1/Synology/Data/OR_Commands/OpenRemote-Controller-2.1.0_FM_SNAPSHOT-2013-07-18
You can do this directly from the NAS, or on another PC and just copy it over, whatever you think is easier for you.
4. Using the Synology web interface, got to the Package Center, find OpenRemote in the installed programs list, and using the 'action' drop-down selector chose "Stop"
5. SSH into your NAS. If using Windows, Putty is a good program for this. Linux and MAC can do this directly from command line e.g.

ssh root@192.168.0.131
Remember to login using the root account. On the Synology devices, the password for this account is the same as whatever you used as the admin account when you setup your NAS using its web interface. If you cant login via SSH, go back to the Web interface of the NAS, go to Control Panel, select "Terminal" and ensure "Enable SSH Service" is ticked.
6. Once you are logged in via SSH, at the command prompt, we need to remove part of the patters package. Type in

rm -rf /volume1/@appstore/OpenRemote/webapps
and hit enter
7. Now type the following to replace what we just remove with your desired version:

cp -r /volume1/Synology/Data/OR_Commands/OpenRemote-Controller-2.1.0_FM_SNAPSHOT-2013-07-18/webapps /volume1/@appstore/OpenRemote/webapps

and hit enter
8. Now you need to change the permissions of the of the folder you just replaced. Type the following

chown -R openremote.users /volume1/@appstore/OpenRemote/webapps

9. You can now close the SSH session. Type in "exit" or close the putty window
10.Now go back to the Synology web interface, got to the Package Center, find OpenRemote in the installed programs list, and using the 'action' drop-down selector chose "Run"
11. In a few seconds, you should be able to connect to the web-interface of the new controller running on the synology. Sync it to your online designer account and you should be up and running. If not, re-examine everything you did carefully. Go back to step 2 if you need to and then try again.

To be fair, most of this information is already in the forums scattered over various posts. I have just put the info together in one place. It works for me and I hope this might be useful to other people.

It would be good if anyone using this post could feed back if it worked for them and perhaps chip in with any improvements or corrections.
There is one other possible method of installing OR, without the patters package, by using the stock Synology Tomcat and Java packages. I haven't tried this myself yet, but maybe someone could do a step-by-step guide using that method?

If I understand correctly, you're upgrading to Pro 1.4.x by just replacing the webapps folder.
This is not enough, there have been changes to the way the controller is launched, so the launch script / mechanism must be adapted.

Certain properties need to be defined for the controller to start correctly.

You at least need to define the following properties:

-Dopenremote.remote.command.service.uri=https://designer.openremote.com/ccs/rest/
-Dopenremote.device.discovery.service.uri=https://designer.openremote.com/dds/rest/
-Dopenremote.sync.service.uri=https://designer.openremote.com/beehive/rest/
Posted by ebariaux at Feb 29, 2016 10:01
Document generated by Confluence on Jun 05, 2016 09:33