This page last changed on Apr 22, 2016 by hennemarc.

Hello Forum,

obviously the User Forum is not really working, so I need to ask this question via the Design Forum.

Does somebody know how to install Java 6 on a Raspberry Pi Model A using the actual Raspbian "Jessie"?
--> https://www.raspberrypi.org/downloads/
--> http://www.oracle.com/technetwork/java/embedded/downloads/javase/default-1934076.html

By following exactly that description and testing it with

pi@raspberrypi:~ $ java -version
java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory

the above mentioned error is always shown.

I checked as well several Java Forums but without success.
I definitively need Java 6 because of drools.

Any ideas from your side how I can get Java 6 running?
Or is there meanwhile a stable version of drools for Java 7 or 8 which works with OR rules?

Marc

Document generated by Confluence on Jun 05, 2016 09:30