This page last changed on May 24, 2013 by johnjore.

Hi!

Trying out openremote as a frontend for DomotiGa, but the android client keeps crashing on a Samsung Galaxy S2 / 4.1.3 during startup (Loading panel: android) does not move on.

Design file works fine via the web, but crashes the android client. (2.0 beta 2)

Uninstall / install and it re-opens, but crashes when browsing to screen 3 out of 4. There's only a few buttons and labes on each screen (1 to 4) and everthing was created through the online designer. Screen 3 worked fine initially, but all this started when adding screen 4. Removed screen 4, still does not work.

Any advice on how to trubleshoot the issue for a fix? (I did press "report" and it said something was sent)

JJ

Edit: Is this client dead? Found the link to Android_Console_2_1_0.apk in a dropbox. Does it replace the Client from Google Play?
Regardless, this client does not crash, but it does not scale the background picture very well. Picture is too big for the screen and is crop'ed?


Croped.png (image/png)

Yes, the Play store is quite old and hasn't been updated in ages, so the one from the DB on this thread is worth testing (sounds like the one you found?) : New Android Console 2.1.0 Beta!

So if the one above does not crash, would go with that APK and then see if there are other issues that need addressing.

Posted by juha at May 24, 2013 15:10

hi and thanks for the confirmation, 2.1.0 beta is not crashing (at the moment anyway)

Is there a way to fix the scaling of the background image? It looks normal in the designer, but image is crop'ed using 2.1.0 beta. This is from the designer, but the image is fullscreen on the device, but the red dot sensor is in the wrong location (a couple of cm further up) On the physical phone, its shown as the same level as the Chair...

JJ

Posted by johnjore at May 24, 2013 15:51

Did you use the last link in the thread?

https://www.dropbox.com/s/01ibptjotwgqlc6/Android_Console_2_1_0.apk

I had a resolution/scaling problem with my nexus 7 and as far as i can remember taking the latest apk fixed the problem.

Orjo

Edit: copied the right link. There are 4 versions in the thread mentioned by juha

Posted by orjo at May 27, 2013 22:14

Hi and just re-tried using the link in your post. The issue is still there.

Does not scale the PNG correctly and the "dot" is in the wrong place.

JJ

Posted by johnjore at May 30, 2013 11:21
Document generated by Confluence on Jun 05, 2016 09:40