This page last changed on Apr 26, 2015 by uglybob.

Hi!

I just started to work again with my home automation project and built a simple panel for controlling my lights with openremote. However, everytime the app is suspended for a while in the background and I try to access it, it crashes. Works fine if I try to start it again. I'm guessing there is a bug in how the app loads it's state when trying to recover from suspended state. Has anyone else notices this? It happens on my Sony Xperia Z3 compact (Android 5.0.2). Will try on my Google nexus too during the day.

Hi.
I have a similar problem on my Sony Xperia E Dual (Android 4.1.1). Ver. OR Controller 2.1.1, ver. Android app 2.2.0. Very often, when I run the application, I get a black screen. I must press Menu, then Logout, select the controller and the panel. I will try to record a video with this problem.

P.S. Here's a video problem: https://www.youtube.com/watch?v=6I2DUgB4b7A
After a few normal run the application, there is a problem. And it happens that a few times in a row there is a problem.

Posted by aleksey_z at Apr 27, 2015 10:06

Yes, I get a black screen with "Unfortunately, Openremote has stopped." too. I guess I could try to get some logs with Android SDK, but haven't had time for that yet...

Posted by uglybob at Apr 27, 2015 10:20

Same issue for me... Hate that it's not 100% reliable.

Posted by niedejb at Apr 29, 2015 22:32

I am getting Android App crash also.

Posted by cwoodhouse at May 17, 2015 16:24

Please try version 2.3.0. http://www.openremote.org/display/forums/Android+Console+2.3.0
Far more stable, only some issues with video. Please supply us feedback at http://www.openremote.org/display/forums/Android+Console+2.3.0

Posted by pierre kil at May 19, 2015 07:49

Fixed crash. Thanks!! I need to fiddle with some scaling problems.

Posted by cwoodhouse at Jun 06, 2015 14:51
Document generated by Confluence on Jun 05, 2016 09:32