This page last changed on Sep 13, 2013 by rpd1146.

I am a new user attempting to evaluate this system with a view to a Home Automation implementation in about three months time.
As I go through the attempts to "Sync with Online Designer" I get the message "Authentication failed, please check your username and password".
I have used the contact link and they have tried to help, but no success so I thought that it might be best to post to the forum as this would probably have a larger audience.
First possible problem was that I hadn't realised that the openremote.org site and designer had separate logins and was hopeful that may have been the problem, but i went through a process of ensuring I had identical logins and passwords for both cases and also, in the (remote) possibility that the download had a parameter inserted that tied it to a particular username, started from scratch with a new download.
I run Windows 7 on a 64 bit system, this is not necessarily where the final installation would run, but it is the environment in which I want to do my evaluation. I followed the XP instructions (there were no instructions for Windows 7) on the page "Install OpenRemote 2.0 Controller".
From the /bin directory I performed the open run as specified on that page.

C:\Paul\Home\HomeAutomation\OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17\bin>openremote run

The following appeared in the window.

Using CATALINA_BASE: C:\Paul\Home\HomeAutomation\OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17
Using CATALINA_HOME: C:\Paul\Home\HomeAutomation\OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17
Using CATALINA_TMPDIR: C:\Paul\Home\HomeAutomation\OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17\temp
Using JRE_HOME: C:\Program Files\Java\jdk1.6.0_45
Sep 13, 2013 8:43:31 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not fou
nd on the java.library.path: C:\Paul\Home\HomeAutomation\OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17\webapps\control
ler\WEB-INF\lib\native
Sep 13, 2013 8:43:31 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Sep 13, 2013 8:43:31 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 894 ms
Sep 13, 2013 8:43:31 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Sep 13, 2013 8:43:31 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Sep 13, 2013 8:43:31 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive webconsole.war
Sep 13, 2013 8:43:38 AM org.openremote.controller.bootstrap.Startup redirectJULtoLog4j
INFO: Initialized JUL to LOG4J Redirector.
INFO 2013-09-13 08:43:41,093 :

********************************************************************************

Controller definition was not found in this OpenRemote Controller instance.

If you are starting the controller for the first time, please use your web
browser to connect to the controller home page and synchronize it with your
online account.

********************************************************************************

Could not find a controller definition to load at path '..\webapps\controller\controller.xml' (for version 2.0)
INFO 2013-09-13 08:43:41,097 : Controller Definition File Watcher for Default Deployer started.
Sep 13, 2013 8:43:41 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Sep 13, 2013 8:43:41 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 9855 ms

At this point it was waiting for me to launch the browser (Firefox). I entered the username and password. Clicking the Sync button produced this message in the window.

ERROR 2013-09-13 08:45:32,962 : Synchronizing controller with online account failed : Authentication failed, please chec
k your username and password.
org.openremote.controller.exception.ConnectionException: Authentication failed, please check your username and password.

followed many lines of the form

at org.openremote.controller.service.Deployer$BeehiveConnection.downloadZip(Deployer.java:1492)

which I haven't listed as it would appear the error has already occurred and been reported.
Sure enough, there is no file controller.xml in the reported directory above, though there are several with that name further down the tree, in sub directories of OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17\webapps\controller\WEB-INF\classes\org\openremote\controller

I think that is the full story. If anyone has any ideas, I would be grateful.

Regards, Paul Dixon

fyi the user an password are case both case sensitive i had the same problem

Posted by jon.gillioz at Sep 16, 2013 13:39
Document generated by Confluence on Jun 05, 2016 09:40