This page last changed on Oct 04, 2013 by ptruman.

Lo again

You can tell I've been able to play with OR today can't you? (post happy!)

I bought a Nexus 7 to control my system, with the intent to let both myself and my wife use it for normal browsing AND remote control.

Android 4.2 brought multiple user profiles to Android for tablets, and I've got that on the Nexus 7. I'm the "main" (first) user and there is a secondary account for my wife.

If I run under my account, the app runs fine, I get my pictures & layouts as intended, all is good.
If I run under my wife's account, all the pictures are grey squares (no images). Even the colorpicker is AWOL. "Default" buttons with no images however, display and work.

I've tried a "restricted profile" with just OR, and it's the same.

Has anyone else tried multiple users on Android and got this result? (obviously I don't want to have to restrict the use of the remote to one user as that buggers up the point of multiple users, not to mention account security).

I've tried "Settings > Logout" just in case there was a panel clash with two instances logged in, but it still does it.
I've also tried creating a second "panel" just for the other account, and that doesn't display images either.

Can anyone else verify this? (anyone with an Android 4.2 (or higher) tablet can check)

The only workaround I can see is to "scrub" my tablet and have the default user the one with OpenRemote, and then setup my "normal" users as sub users, but that's ugly as we'd have to switch accounts to use OR.

If I get a chance later I'll try the forum version of the client, but my only assumption is that on Android, the client must store graphics somewhere which, when users switch, the other users don't get access too....

Posted by ptruman at Oct 08, 2013 10:28

Can any of the devs clarify where/how the OR Android client (store version) keeps graphics? Is it writing them as binary strings into SQLite, or is it shoving them as files? (if it's files, I can maybe try to add a+r to them to see if the other profiles can access the graphics.

Posted by ptruman at Oct 08, 2013 10:45

Right, have now tried using OpenRemote-2.0-Android_SNAPSHOT_20111012.apk on both "main" and a sub-user on Android 4.3

On a sub user, nothing (at all) displays, not even the greyed out icons I got before.

I suspect the only way I'm going to get this to work (unless someone can identify this and release a fix?) will be to blank the tablet and setup the primary user as "the remote" user, and put the other users (i.e. me!) as sub accounts - which is less than ideal.... :\

Posted by ptruman at Oct 10, 2013 10:54

Hi Peter,

Thanks for documenting the issues here. Rainer Hitz was planning to get a Nexus 7 so we'll see if he can reproduce the issue and better yet, if he has a chance to see if there's a simple fix for it. So at the moment just waiting to see what happens. Richard Turner is also going to have some Android related work ahead of him so we'll try to see if it would be possible to check/address the issue at that time. But currently he's tied up with other non-Android related work. So for the moment, we'll just have to wait a bit longer before getting to this.

Thanks for bringing it to our attention though, and hope to have a better response to this later.

Posted by juha at Oct 10, 2013 11:01

Not a problem - I really want to deploy this into the house - my decorating is nearly finished, and the plan is to use the Nexus as the control planel but not upset the wife

I'm happy to be a beta tester for new versions

Posted by ptruman at Oct 10, 2013 18:29

It looks like Rainer has started to dig into the issue: ANDROID-104

Posted by juha at Oct 15, 2013 17:11

Good stuff. As mentioned, am willing to play guinea pig.
So far, I've got OR wired up to talk to :

a) Philips Hue (3 bulbs, 1 lightstrip) - 2 way comms
b) Global Cache IP2IR device (talking to a TV, UK TiVo and imminently a Hotbox gas fire)
c) UK Tivo (via Telnet - but need IR for a couple of specific functions)
d) LightwaveRF (relay for central heating override, and three on/off plugs for some fixed socket based lights) - and I'll REALLY like UDPListener to be implemented for some basic 2 ways comms
e) Onkyo amp (via TCPIP) - 2 way comms sort of working (my Regex fu is less than ideal)

I'm also hoping to get a WebView to work with my IP camera, but it's an ASF feed (works in Chrome ok), but not in the store version of the app.

Given the room decoration has finished, I'm going to have to re-flash the Nexus 7 back to stock so it can be used by my wife - but it'll still be multi-user so I can test it

Posted by ptruman at Oct 18, 2013 15:32
Document generated by Confluence on Jun 05, 2016 09:29