This page last changed on Jun 12, 2014 by technicallygky.

I've setup serial commands to control Qmotion blinds and setup buttons for those commands, but I can't get it to send a command a second time if I click the button a second time. For example, if I click blinds up button, the blinds will raise. I can then click the blinds down button and they will lower. If I go to click up again, nothing happens. I created a second up button that runs the same command as the first and I can get it to work one time also. Is there any way to get a button to work more than once?

It seems that your command hangs during execution. Do you see any errors in dev.log?

Posted by aktur at Jun 12, 2014 15:42

Nope... no errors. The command sent is in hex - 0x01070005010A0100F7 to raise, and 0x01070005010A0200F4 to lower. With a serial port monitor I see that I am getting a 5C as a response for any command sent.

Posted by technicallygky at Jun 12, 2014 16:41

I guess I should explain a little more to clarify - I can run the command multiple times, but the button won't work a second time. If I create 3 up buttons all using the same up command and 3 down buttons all using the same down command, I can raise and lower the blinds 3 times. After that, all of the buttons have been clicked once and will not respond to a 2nd click.

Posted by technicallygky at Jun 13, 2014 11:19

With what console do you see this behaviour ? If web, on what OS/browser ?
Have you tried the same design on another console ?

Posted by ebariaux at Jun 14, 2014 19:21

It was indeed web console, chrome browser. I'm doing the work remotely and testing thru web console as I add things. I just arrived on-site and tried the app on my android phone which worked flawlessly. Thanks for the response.

Posted by technicallygky at Jun 16, 2014 19:14

This sounds a little odd to me and is something I've never encountered or that I can explain. If you are using a button then they are completely stateless so there is no reason why the command should execute only once.

Just before you press the button in the web console do Ctrl+Shift+C and go to the Network tab, each time you click the button you should see a network message appear in the list which will be the REST API call to send the command. Can you let us know if you get a network message in there each time you press the button?

Posted by kurrazyman at Jun 17, 2014 17:15

I'll check this today and let you know.

Posted by technicallygky at Jun 18, 2014 11:14
Document generated by Confluence on Jun 05, 2016 09:34