This page last changed on Dec 09, 2015 by nfettinger.

I am using an Ubuntu x64 server, installed according to wiki.
I gave full read/write/execute permissions to the entire OpenRemote folder located in /opt/OpenRemote
I updated the config file to use an absolute path for the logs versus the relative one (so I could start it outside of the local directory).
When using sudo (root) the controller starts normally and the application responds to requests.
When not using the sudo command, I get these errors.

fetty@Ramsley:~$ /opt/OpenRemote/bin/openremote.sh run
Using CATALINA_BASE:   /opt/OpenRemote
Using CATALINA_HOME:   /opt/OpenRemote
Using CATALINA_TMPDIR: /opt/OpenRemote/temp
Using JRE_HOME:       /usr

---- Logging ----------------------------------------------------------

 Console (stdout) threshold [CONTROLLER_CONSOLE_THRESHOLD]: INFO

 System logs:

   - Controller startup log [CONTROLLER_STARTUP_LOG_LEVEL]: DEBUG
     

-----------------------------------------------------------------------
Dec 8, 2015 8:47:53 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /opt/OpenRemote/webapps/controller/WEB-INF/lib/native
Dec 8, 2015 8:47:53 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8688
Dec 8, 2015 8:47:53 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 395 ms
Dec 8, 2015 8:47:53 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Dec 8, 2015 8:47:53 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Dec 8, 2015 8:47:53 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive webconsole.war
log4j:ERROR setFile(null,true) call failed.
java.io.FileNotFoundException: ../logs/dev/dev.log (Permission denied)
	at java.io.FileOutputStream.openAppend(Native Method)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:210)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
	at org.apache.log4j.FileAppender.setFile(FileAppender.java:289)
	at org.apache.log4j.RollingFileAppender.setFile(RollingFileAppender.java:165)
	at org.apache.log4j.FileAppender.activateOptions(FileAppender.java:163)
	at org.apache.log4j.config.PropertySetter.activate(PropertySetter.java:256)
	at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:132)
	...

What sort of users/permissions do I need to set up in order to fix this, currently the owner of everything in the OpenRemote directory is root:root.

Seems logs are created relative to the directory you're launching OR from.

cd into /opt/OpenRemote/bin and then execute ./openremote.sh run

Posted by ebariaux at Dec 09, 2015 14:50

I've already tried that and I get the same exact error sequence.

fetty@Ramsley:~$ cd /opt/OpenRemote/bin
fetty@Ramsley:/opt/OpenRemote/bin$ ./openremote.sh run
...
INFO: Deploying web application archive webconsole.war
log4j:ERROR setFile(null,true) call failed.
     java.io.FileNotFoundException: ../logs/zwave/zwave.log (Permission denied)
     ...
Posted by nfettinger at Dec 10, 2015 02:29

The log file cannot be created, opened, or written in the location desired. Newer Linuxes are getting more and more restrictive here, selinux just to mention one thing.

Try to, at least as a test, specify a log file in a place where you definitely can write, like /tmp.

Posted by barf at Dec 11, 2015 09:24

Thanks for the suggestion, I tried this as well as giving full permissions to the /dev/ttyUSB0 device, and that got me going on the right track. I am still having trouble getting through all of them though. After the initial sequence, this is displayed (in the log, and partially in the terminal) every second until I stop the controller. Username removed for privacy. I cant tell what access violation is preventing the controller from doing what it is trying to do here.

INFO 2015-12-12 18:16:01,728 : Unable to retrieve controller identity, retrying in 1,000 milliseconds...
INFO 2015-12-12 18:16:01,728 : Unable to retrieve controller identity, retrying in 1,000 milliseconds...
TRACE 2015-12-12 18:16:03,154 : Unable to retrieve controller identity
org.openremote.controller.exception.ConnectionException: The required password for user '####' was not found. Password manager error : Error accessing users password: {0}
	at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.connect(Unknown Source)
	at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.httpRequest(Unknown Source)
	at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.httpPost(Unknown Source)
	at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.getControllerIdentity(Unknown Source)
	at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.getRemoteCommandService(Unknown Source)
	at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.run(Unknown Source)
	at java.lang.Thread.run(Thread.java:701)
Caused by: org.openremote.controller.service.Deployer$PasswordException: Error accessing users password: {0}
	at org.openremote.controller.service.Deployer.getPassword(Unknown Source)
	... 7 more
Posted by nfettinger at Dec 13, 2015 00:33
Document generated by Confluence on Jun 05, 2016 09:32