This page last changed on Apr 08, 2013 by parityher0.

Everytime i try to create an account, it says the username is not available..

Hi all,
I'm having the same problem - every username variant is 'not available.
With thanks, Matt

Posted by msachse at Apr 08, 2013 04:47

Same. I found it unlikely that my username was taken, so I tested with some linenoise usernames:

79UtCqrhbxTeU and wSMXDHHJQLMfY are apparently registered already.

Admins, double-check the site for us would ya?

Posted by jbevren at Apr 08, 2013 12:33

Just tried, and was able to create a new account without issues.

What is the web browser/version/operating system you are using?

Posted by juha at Apr 08, 2013 13:24

Also, just in case, can you try clearing your browser's cache?

Posted by juha at Apr 08, 2013 13:25

Firefox 19.0.2 (Build identifier: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0).

I failed to create any account on initial use of the demo designer website, so cache should be irrelevant. However, that's a great suggestion so I cleared all cookies for today (from Midnight forward) as well as removed all cache data for the browser.

Still no luck.

Posted by jbevren at Apr 08, 2013 13:33

Hmm, puzzling.

I tried Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0

and account creation still worked. I can still try to fire up a Linux VM and see if there's anything different.

In the meantime, do you have any extension installed on Firefox that might interfere? Cookies enabled? Javascript enabled? Any grease monkeying going on?

Posted by juha at Apr 08, 2013 13:47

Just to add to my experience, I've tried from my work network (older version of IE), and tonight from home on Chrome, Firefox and IE (latest) I continually get any username is not available, choose another.
The URL I land at is http://composer.openremote.org/demo/account.htm?method=create

Hope this helps.

Posted by msachse at Apr 08, 2013 13:56

Is it possible that my repeated attempts got my IP address marked as a suspect spammer?

I read in another thread that a piece of software reports the username as unavailable regardless of the error as well, would this be related?

Posted by jbevren at Apr 08, 2013 14:11

Yes, any error is probably going to show up (mistakenly) as username is taken.

I went through the logs of today but couldn't see anything out of the ordinary on the exception stack traces. The only one case related to IP addresses I can remember was a suspected XSS attack which was caused by a funky proxy setup. But didn't see XSS alerts today either.

Feel free to email me any information I could use to identify your attempts, username, times, etc. at juha openremote org

Posted by juha at Apr 08, 2013 14:23

Ok, there's an issue with the mail relay (denied). So the registration emails aren't getting sent out. Mine worked because of the openremote.org domain.

Posted by juha at Apr 08, 2013 14:30

Thanks for the update Juha. I'll wait for an update regarding your email relay before any additional testing.

Meanwhile I sent a private email with some details in case they're handy.

-Jonas

Posted by jbevren at Apr 08, 2013 14:48

Please try this again now. You may need to use another username you didn't try registering with yet, since the registration got sort of broken in the middle of the process. Or you can try and see if the password reset would work for any of the account names you wanted to use (assuming you can't register with the original username again).

But first just try to re-register with your original username or just pick something you didn't try yet.

If it's really really important to use an account name that got taken by the broken registration and you can't re-register with that name and you can't get password reset on the account name either, leave a note here. Please do it soon before I switch context to another task again because later it will take longer time for me to get back to it. I will try to recreate your account with your original username.

Posted by juha at Apr 08, 2013 15:55

Posting here for everyone else's record.

I'm able to create and log in with a new username now. I'm working with Juha regarding the original username I attempted earlier.

Thanks guys!!

Posted by jbevren at Apr 08, 2013 15:58

Fixed for me - thanks.
I had to pick a new username I hadn't tried. Original ones failed.

Posted by msachse at Apr 09, 2013 02:06
Document generated by Confluence on Jun 05, 2016 09:40