This page last changed on May 15, 2015 by mediator123.

Hi there,

i just added the color-picker to my visualization but unfortunately this seems to be a dead end

What I did:
1.) Created a new command in the designer like this:
Name "Pool_LED"
Protocol "KNX"
Group Address "1/3/125"
KNX Command "RGB"
DPT "232.600"

2.) Added the "color Picker" to the panel

3.) Used "Pool_LED" as command for the color picker.

I updated everything, but if I tap on the "cool picker" on my iphone nothing happens. I look at the traffic on my KNX bus there is absolutely no sign of life

Has anyone an idea, what I´m doing wrong?

Thank you in advance!
Christoph

Which OR version do you use?

Posted by mredeker at May 16, 2015 21:30

Hi Marcus,

thank you for your response!

I use the following Versions:

  • On my NAS is the OR Version 2.0.1-0008 running
  • On my iPhone I use the Version 2.1.3
  • the Designer is Version 2.14.0 (but that one an online application anyway )

Just in case the version of my controller is too old, can you tell me which one I have to download (and where?). I use a Synology DS212j to run the controller.

Thank you for your help in advance!
Christoph

Posted by mediator123 at May 17, 2015 15:18

Do you find the following file withing your openremote/webapps/controller/web-inf/classes folder:
org/openremote/controller/protocol/knx/datatype/ThreeByteValue.class

If not, your version does not include the KNX RGB stuff.

Posted by mredeker at May 17, 2015 21:04

Hi Marcus,

thank you! At least I know now where the problem is coming from - Indeed the ThreeByteValue.class is not available in the mentioned location.

Do you have any clue how I can fix this problem on my Synology DS212j NAS?

Thanks!
Christoph

Posted by mediator123 at May 18, 2015 20:00

The latest controller download (version 2.1) should include the necessary stuff.
You can try and replace your Syno install with that.

Posted by mredeker at May 19, 2015 20:05

Hi Marcus,

I updated to the version 2.1 following the instructions here -> http://www.openremote.org/display/docs/OpenRemote+2.0+How+To+-+Controller+on+Synology+NAS?focusedCommentId=22883846#comment-22883846

Now it works! Thank you very much!!!

Posted by mediator123 at May 20, 2015 20:16
Document generated by Confluence on Jun 05, 2016 09:32