This page last changed on Feb 04, 2015 by jimself.

Hi,
I switched to 2.1 and upgraded my QNAP TS212 controller connected to my KNX installation.
Unfortunately I don't get a reliable setup up and running. I persistantly get this KNX.log error message:

Service failed
org.openremote.controller.protocol.knx.ip.KnxIpException: Service failed, no ACK

followed by

Service failed
java.net.SocketException: Socket is closed

Everything was running smoothly over weeks before. So I tend to switch back to the working setup.

Hi Jim,

I have the same problem when I switched to the latest controller.
Have you managed to solve it?

Thanks

Gideon

Posted by gheinert at Oct 29, 2015 11:25

Hi Gideon,

if I remember correctly, I just made a stupid mistake and forgot to enter the correct knx IP address in the config.properties file.
See here under "configuration of system".

Regards
Andi

Posted by jimself at Oct 29, 2015 20:56

Hi Andi,

Thanks for the reply.
Not sure whether I have the same problem then. Checked the config file and I have the correct ip address. Also the same knx command works several times correctly and then it suddenly crashes.
I have also tried tried to specify no ip address in the config file so that the controller uses the first available knx interface. But I still get the same error.
Maybe I just go back to earlier controller version, which was working fine.

Best wishes

Gideon

Posted by gheinert at Oct 31, 2015 11:08
Document generated by Confluence on Jun 05, 2016 09:34