This page last changed on Jun 19, 2012 by demo.

The bug faces with "Custom state items" of custom sensor, I get duplicated items any time I press on the submit button.

To reproduce this bug, create a new sensor, set its name, command, type as custom and add some states, then click on submit. From now, any time you edit the sensor and click on submit button, the Designer duplicate its "Custom state items".

In order to check the duplicate items, and since they are not visible in the sersor edit window, you should add a new image in the Designer UI and bind it to the sensor. Now you can see all duplicates.

  • - -
    max

Thanks for reporting this, I'll take a look.

Just to be clear, when you say

since they are not visible in the sersor edit window

you mean that the duplicates are not visible in that window, right ?

Because when I edit a custom sensor, I get a table at the bottom of the edit window, listing the "Custom state items".
But indeed in that table, I never see duplicates, I see what seems to be the correct list and it's only when using the sensor that the list is wrong.

Posted by ebariaux at Jun 19, 2012 13:30

yes, it is correct.

The duplicates shows up only when the sensor will be used in the Designer UI.

ps. can you make all the windows fluid in the way that if I enlarge a window the contents gets more visibility?
Working on little space make things more hard.

Thank you.

Posted by demo at Jun 19, 2012 14:56

I concur this. Happened to me tonight. Had to delete the sensor and start again.

Posted by mbarne36 at Jun 19, 2012 20:34

Thanks to both, I identified the issue and a fix should be coming soon. I'll post as soon as it's available in the online designer.

Posted by ebariaux at Jun 20, 2012 16:04

Version 2.13.3 which is now on-line should fix this.

Posted by ebariaux at Jul 28, 2012 07:17
Document generated by Confluence on Jun 05, 2016 09:30