This page last changed on Feb 09, 2016 by tcagle53.

I have a webconsole remote I've designed and used successfully on my home entertainment system for around three or four years now. Recently, I've begun to encounter an issue with the designer that is driving me nuts. I have 8 screen and ~250 buttons. Late last year I attempted to add four more panels: DVD player, and three additional Roku related panels to enable easy setup of roku channels via keyboard entry screens. The gist of the problem is that when I make a relatively small change to my startup screen (for example) it throws all my commands on the roku keyboard panels out of sync somehow (and seemingly at random). Example: I press the lowercase "a" button and it send the uppercase "F" from a completely different screen. When this happens, the only recourse has been to delete the affected screens and start over from templates and completely reassign all one-hundred plus commands carefully in the correct order again. This was occurring under the default group originally. I've since tried grouping the new screens several different ways and nothing seems to prevent this from occurring. Here is a shot of my designer groupings as of now. I've done this several times now and my tolerance for this nonsense is reaching the breaking point.

My controller version is: OpenRemote-Controller-2.1.0_FM_SNAPSHOT-2013-07-18
The webconsole version is a snapshot from mid july 2013

Would getting more current versions of the above stuff be of any value?

Anybody have ideas on how to avoid this issue or correct it more easily when it occurs?

Thanks for listening.

screen shot


Solved for myself. I just discovered that the designer sync is what is getting the commands scrambled. If I go immediately and restart the controller all is well again. It apparently is to do with some sort of memory management bug or something on the controller. Sadly, I never figured out how to integrate the startup into my ubuntu precise services and instead rely on a clunky @reboot cron entry to start my controller so I don't really have a clean way to restart my controller save just shutting down and rebooting the darn thing but at least now I know that it is definitely NOT an actual designer problem.

Posted by tcagle53 at Feb 09, 2016 18:53
Document generated by Confluence on Jun 05, 2016 09:33