This page last changed on Dec 11, 2013 by jonny1970.

Hello,

I started few days ago my adventure in Z-Wave

I have one Aeotec Z-Stick S2 and 2 duwi ZW ZS switch

I have installed Openremote on my pc win 8 (I have also a Raspberry ... but it will be the next step)

The Z-Stick sims plugged correctly

I tried lot of time to follow the instruction conteined in the doc: Discover Controller Z-Wave Devices ... but I continue to have an empty zwave.log, so I have no idea how to add my two switch.

Can someone help me pls ?

thank you in advance

I had it, when it did "Download and save the zwave.jar file into the folder "OpenRemote-Controller-2.1.0/webapps/controller/WEB-INF/lib" from "How To - Z-Wave"

Posted by preston at Dec 12, 2013 07:37

Unfortunalety I have already tried. Nothing happens.

One more info, here the log starting the openremote (openremote run)

E:\OpenRemote-Controller-2.1.0\bin>openremote run
Using CATALINA_BASE: E:\OpenRemote-Controller-2.1.0
Using CATALINA_HOME: E:\OpenRemote-Controller-2.1.0
Using CATALINA_TMPDIR: E:\OpenRemote-Controller-2.1.0\temp
Using JRE_HOME: E:\SW_64Bit\Java_devel_kit_6u21
14-dic-2013 10.30.51 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performanc
e in production environments was not found on the java.library.path: E:\OpenRemo
te-Controller-2.1.0\webapps\controller\WEB-INF\lib\native
14-dic-2013 10.30.51 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
14-dic-2013 10.30.51 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1282 ms
14-dic-2013 10.30.51 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
14-dic-2013 10.30.51 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
14-dic-2013 10.30.51 org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive webconsole.war
14-dic-2013 10.30.54 org.openremote.controller.bootstrap.Startup redirectJULtoLo
g4j
INFO: Initialized JUL to LOG4J Redirector.
INFO 2013-12-14 10:31:00,087 :

--------------------------------------------------------------------

DEPLOYING NEW CONTROLLER RUNTIME...

--------------------------------------------------------------------

java.lang.UnsatisfiedLinkError: E:\OpenRemote-Controller-2.1.0\webapps\controlle
r\WEB-INF\lib\native\rxtxSerial.dll: Can't load IA 32-bit .dll on a AMD 64-bit p
latform thrown while loading gnu.io.RXTXCommDriver
Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: E:\OpenRemote-Con
troller-2.1.0\webapps\controller\WEB-INF\lib\native\rxtxSerial.dll: Can't load I
A 32-bit .dll on a AMD 64-bit platform
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1803)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1728)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1028)
at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:123)
at org.openremote.controller.protocol.zwave.ZWaveGatewayRxtx$ZWaveConnec
tionThread.run(ZWaveGatewayRxtx.java:108)
INFO 2013-12-14 10:31:10,343 : No rule definitions found in 'E:\OpenRemote-Contr
oller-2.1.0\webapps\controller\rules'.
INFO 2013-12-14 10:31:10,343 : Initialized event processor : Drools Rule Engine
INFO 2013-12-14 10:31:10,604 : Initialized event processor : RRD4J Data Logger
INFO 2013-12-14 10:31:10,605 : Initialized event processor : EmonCMS Data Logger
INFO 2013-12-14 10:31:10,607 : Startup complete.
INFO 2013-12-14 10:31:10,608 : Controller Definition File Watcher for Default Deployer started.
14-dic-2013 10.31.10 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
14-dic-2013 10.31.10 org.apache.catalina.startup.Catalina start
INFO: Server startup in 19682 ms

Is it a problem the message about the rxtxSerial.dll ?

Posted by jonny1970 at Dec 14, 2013 09:35

It looks like a rxtxSerial on 64bit platform problem. Use the search function on this site with search terms "rxtxSerial 64".
I found this thread that might help you: No log of zwave stick

PS: For better readability you could enclose your code within {code}..{code} tags (see markup instructions). Do not place a / inside the end tag.
Formatting makes the code easier to read, which increases your chances to get an answer

Posted by pz1 at Dec 14, 2013 09:49

Thank you for the suggestions ... great it works

.... my next step is now use the raspberry-pi instead of my PC win8 ... let's see

Posted by jonny1970 at Dec 16, 2013 20:50
Document generated by Confluence on Jun 05, 2016 09:35