This page last changed on Dec 10, 2012 by jbesnil.

Hello all,
I've asked the same question on user forum.. i wasnt sure if it is the right forum.

I downloaded the source code of Designer-Rosemary and succefully build it.
When i try to deploy web application archive, i constantly receive this error:

org.apache.catalina.core.StandardContext start
Error listenerStart

I want to start the Designer locally on my machine and thats why i need this.
I have integrated all other segments web console, controller, beehive DB and UI_Composer.
But still cannot get web access to http://loaclhost:8080/modeler.

Thanks for help

Somewhere during the deployment an error must occur, that's why you receive the error you mentioned above.
If the listener does not start up, no access to tomcat is available.
There should be some kind of stacktrace in the log files.

Posted by mredeker at Dec 11, 2012 09:03

Thanks Marcus, i solved the problem and successfully deployed web application archive.
But i don't understand why i still can't connect to Designer's page(locally on my server).
Is there some user guide on how to set the designer locally?
I've set all the config files, i receive no errors and i don't know where should i look for the solution.
I checked the ApplicationView.java file.. Is it maybe authorization problem?

Posted by jbesnil at Dec 11, 2012 14:17

If everything deploys find and you don't have any error, you should be able to access the designer with the URL you mentioned earlier.
Do you mean the webpage or the controller downloading the design?

Posted by mredeker at Dec 11, 2012 14:41

Controller works fine.. I meant the web page of designer(modeler). It should be accessible on http://localhost:8080/modeler

Posted by jbesnil at Dec 11, 2012 14:49

That can only mean that modeler.war was not deployed correct.

Posted by mredeker at Dec 11, 2012 15:03

Check the name of the war file that gets generated and deployed.
I don't know what branch you're using but the latest build script will create a war such as Designer-2.13.0-2012-06-01-Rosemary.war and so the modeler will be accessible at http://localhost:8080/Designer-2.13.0-2012-06-01-Rosemary not /modeler

Posted by ebariaux at Dec 12, 2012 10:03

Thank you for the support, i have solved the problem 3 days ago, changing the name of the war packet from Designer-2.13.0-2012-06-01-Rosemary.war to modeler.war. But there was actually another problem which i traced in the log file.
The problem was that UIComponent.java and BusinessEntity.java have different return types and the error i traced was:

"java name clash: list<BeanModel> createModels(Collection <? extends BusinessEntity> list) in BusinessEntity.java and list<BeanModel> createModels(Collection <? extends UIComponent> list)in UIComponent.java have the same erasure, yet neither hides the other"

I figured out that this concept is only allowed in java6 and java7 forbids it. After installing java6 instead of java7 i got problem solved.

Similiar question was posted on StackOverflow: http://stackoverflow.com/questions/6643648/java-static-method-binding-and-generics-all-rolled-up-with-some-method-overload

Posted by jbesnil at Dec 15, 2012 08:21
Document generated by Confluence on Jun 05, 2016 09:30