This page last changed on Dec 23, 2015 by mike.schmidt.

I have been running Pro 1.3 without issue. I run OR on a full Tomcat installation and just put the controller app in the webapps folder. This normally works well. When i replace the 1.3 folder with the 1.4 folder, i get an error trying to sync. The error states "An attempt was made to access service context before it was initialized."

I also noticed that when i load the controller webpage that it does not seem to try and connect to the cloud to see if the controller is associated to my account. When i use 1.3, the webpage indicates that the controller is associate to an account, or will tell me to register using the server MAC address. With 1.4, i do not get either of those messages on the web interface.

It appears that maybe i am missing something with the config of 1.4. I read in the change logs that 1.4 introduces a new method of connecting to beehive, so maybe i need to add some information to the configuration parameters. Can anyone help point me in the right direction?

Mike

Disregard this post. I have resolved the issue. I copied the config.properties file from the 1.3 controller to the 1.4 folder and everything is fine. I noticed that some of the URLs for the Beehive rest service are different in the 1.4 config, and my pro user account was getting access denied when browsing to the 1.4 URLs. With the !.3 config file, everything seems to work as expected.

Mike

On which platform do you run OR 1.4?

Posted by pz1 at Dec 23, 2015 21:12

I run the OR controller on Windows 2012 R2 server using a full Tomcat 9 installation. It works quite well, just this little issue with the 1.4 config.properties file. Since I started using the 1.3 config.properties, it is working OK. One side note, when I use a full Tomcat install, I have to change all of the relative path statements in the log4j and config properties files to use ./path/to/log instead of ../path/to/log

Posted by mike.schmidt at Dec 23, 2015 22:51

Thanks for the information. I have problems on Synology. Posted about that in the 1.4 release thread

Posted by pz1 at Dec 24, 2015 08:14

Pro 1.4.0 introduced the possibility to configure some of the OR parameters through environment variable.
The config.properties file does now contain placeholders and expects some Java properties to be set. If they are not, launch will fail.

The openremote.bat script provided with the Tomcat distribution included in Pro 1.4.0 does set those properties based on the environment variables or using default values.
If you're running in your own tomcat, you need to make sure those properties are also defined.

Posted by ebariaux at Jan 04, 2016 13:14

If you're running in your own tomcat, you need to make sure those properties are also defined

I do run the tomcat that comes in the Pro 1.4 ZIP. Should I adapt file config.properties?

Update: Just did a new 1.4-controller download. Did not see anything that looked like placeholders for Java properties in controller/WEB-INF/classs/config.properties

Posted by pz1 at Jan 04, 2016 13:25
Document generated by Confluence on Jun 05, 2016 09:33