This page last changed on Feb 02, 2015 by kslate.

I recently have jumped back into openremote after being away from the design stage for over a year. Upon trying to design a new screen, I've noticed that my uploaded image names don't seem to match the correct image. The image is named one thing but shows a completely different image in the image quick view as well as on the screen. If I upload a new image, it works as expected but when I go to select that same image again, it is a completely different image but named the same as the one I uploaded.

I'm still running version 2.0 so I'm not sure if that is an issue or not? I'm running 2.0 because I don't completely remember how I got it working on a Win 7 box in the first place. I remember having to do a bunch of customization in order to get things working (tomcat install as well as editing a bunch of files) and when I try to use version 2.1 things just don't work at all. I'm guessing I have to figure out all the files I changed and change them again... kind of a pain to do.

Any thoughts on why this image thing is happening? I tried searching the forums but did not find a similar issue.


IMG_0464.PNG (image/png)

I noticed the same behavior. At least the thumbnails are correct so I can select the right one based on the image I see rather than the name.

PS. I'm using controller 2.1

Posted by aptalca at Feb 02, 2015 21:22

As a temp solution, you can click on the Name column to re-order the list. This will line things up again.

Posted by ictesecurity at Feb 02, 2015 21:44

Can you maybe post a screenshot, I could not reproduce and I'm not sure I fully understand your problem?

Also, can you indicate which platform/browser/version you're using?

Thanks

Posted by ebariaux at Feb 08, 2015 11:47

Hi.

Long time since I have added something to my project. This has happned to me as well. I have removed one panel as I have replaced my H/W and sotarted adding a new one identical to the others but with different resolution.
I have a gree button and red one with dew sizes and unique names.
All of a sudden, the list of exitinf images is much shorter then what is realy being used, selecting an image of of my disk is not being remembered and when I try to use an exiting image of a button to be attached to a switch I get a different iamge (one being used as the screen background).
It looks like the DB of the images has a bug.
I am still in the designed, running under Linux MINT 17 and Google Chrome.
Can't get the job done.

Posted by niraviry at Mar 14, 2015 19:31

I'd attach a screen shot but not sure how to do that. Sorry for the delay but the solution is to re-sort the images (as ICT states). Not really all that convenient but it does fix the issue (but you have to do it every time).

Windows 8.1 and had this happen in version 2.1.0 and 2.2.0.

And Chrome Version 40.0.2214.115 m

Can't attach but can point to it:

http://www.slatehouse.net/tmp/error.png

Note: the image selected is NOT sony.png.

Posted by kslate at Mar 14, 2015 20:07

Hi.

Things for me are about the same but with my icons (png files).

Posted by niraviry at Mar 14, 2015 20:23

Checked the Sorting bypass and it works but each time I open a new image for a switch or any other ite, it needs sorting.
Furthermore, when opening the add image button for getting a new image, the parent popup window is in the background. The only way to upload a new image from my disk is to close the parent windows, otherwise, the child (image upload) is greyed out and can not be selected.
I an using fully updated Linux MINT 17 & google chrome.

Posted by niraviry at Mar 18, 2015 18:22

Hi,
I have the same problem,
but the images that I post in the bottom bar does not appear why? you solved?

Posted by gciman at Mar 20, 2015 14:55
Document generated by Confluence on Jun 05, 2016 09:37