This page last changed on Nov 19, 2012 by teknoir.

Ok, I've gotten the hang of ETS and OpenRemote Controller 2.0.0. All my programming is working fine except the SCENE commands.

I've tried to debug this problem but I'm not sure about the results.

Comparing the values I get when I use ETS to set the scene and using OR I thought I had the solution.

For example using an OR command:
SCENE 1
17.001

Generates in the groupdiagnostics in ETS:
RAW DP value: $81
(should be $00, that is wat works and what ETS sets for above example)

My idea was that it had got mixed up with LEARN_SCENE, but I'm a bit confused.

Looking at the code:
return new ApplicationProtocolDataUnit(
ApplicationLayer.Service.GROUPVALUE_WRITE,
new Unsigned8Bit(
DataPointType.Unsigned8BitValue.VALUE_1_UCOUNT,
learn ? value : 0x80 | value)
);

It looks correct in my eyes and I've checked the calls and it seems to set learn correctly.
I also tried to outsmart the system and put in LEARN_SCENE 1 but it still got $81.
If I try different scene numbers it seems to always bitwise include 0x80, so I see another problem. It should be -1 swell.

Any ideas anyone?

Hi,
there is mistake in controller. Try learn_scene inspite of scene. Take also minus 1. Eg to play scene 18 -> learn_scene 17 with 18.001 inspite of 17.001
BR
Grzegorz

Posted by profox at Nov 19, 2012 20:08

Hi!

Yes that worked! Thank you!

I forgot to put in 18.001 with LEARN_SCENE and -1 on the number. Now my scenes works perfect.

Cheers!
Anders

Posted by teknoir at Nov 20, 2012 06:11

Fell free to submit a patch
Thanks.

Posted by mredeker at Nov 20, 2012 08:07

I'll set up a dev environment on a virtual machine this weekend. I need to be able to test the changes be4 submitting a patch.

I would love to make a contribution to this wonderful project!

Cheers!
Anders

Posted by teknoir at Nov 20, 2012 08:26

I added a patch in this forum post: http://www.openremote.org/display/forums/Status+scene+change%2C+telnet+status%2C+key+press+delay?focusedCommentId=21039096#comment-21039096
The patch is for the 2.1-developer-snapshot.

Posted by mredeker at Dec 26, 2012 23:40
Document generated by Confluence on Jun 05, 2016 09:31