This page last changed on Sep 19, 2011 by hihi.

HI All,

I know there is this tutorial to import the KNX database: http://openremote.org/display/docs/OpenRemote+2.0+How+To+-+KNX+ETS4+Import

I'm using the online OpenRemote Boss 2.0 but I don't have this option to import the database .... do I have to activate it anywhere?

thanks,


import error.png (image/png)

The version of the modeller which is currently on the website does not include this option yet.

Posted by mredeker at Sep 20, 2011 08:28

Oh, ok, any idea when it will become available?

Posted by hihi at Sep 20, 2011 10:34

No, I don't know yet. The branch has to be merged into some other stuff which was done from other community members.

Posted by mredeker at Sep 22, 2011 07:51

Any news on the new interface supporting KNX?

Thank you for your time!

Posted by hihi at Nov 21, 2011 22:26

It's next on the agenda since the 2.0 controller is almost ready.
But the designer still needs merging and testing.
We don't have a date yet.

Posted by mredeker at Nov 21, 2011 23:04

Hi Marcus,

Thank you for your swift reply.

Not that I want to rush anyone ... but do you have a time indication in weeks? (will it be a present for Xmas or sooner)

Posted by hihi at Nov 23, 2011 16:10

It'll be out before xmas.

Posted by juha at Nov 23, 2011 16:36

Hi Juha,

Not to be annoying, but any idea on timing of this track?

Posted by hihi at Dec 08, 2011 15:17

This week, unless there are unexpected issues that pop up.

Posted by juha at Dec 08, 2011 15:23

Hi Juha,

Does the current online designer supports KNX import? Or did something went wrong during the upgrade?

Thanks,

Posted by hihi at Dec 13, 2011 14:10

You can give it a test try at http://composer.openremote.org/staging.

I'll probably move it over to the live demo URL sometime today.

Thanks,

– Juha

Posted by juha at Dec 13, 2011 14:31

Juha

do you have a list of change for this release of designer?

Pierce

Posted by pjmm at Dec 13, 2011 21:03

Compared to the one from a week ago (Dec 5th), it only adds the KNX import feature.

Posted by juha at Dec 14, 2011 08:04

Juha,
If we us this link, are we going to keep our commands/panel developments when moving to the final release of the composer?
Regards
Yann

Posted by yannph at Dec 14, 2011 08:26

Hi Juha

do you have a list of changes for the release of the 5th Dec hasthe ability
to have HEX and HEX-ASCII in commands made it into the Designer yet.

Pierce

Posted by pjmm at Dec 14, 2011 18:12

Is there someone who've tested this version (Alpha 9 - Voldemort) from 12122011?
After selecting the KNXPROJ file (2MB) and hitting the "Load" button, nothing happens.
Looking at my network stats, the files seems to be uploaded. But that's it.
I've tried with IE9(32/64) & Firefox 9Beta

Any idea? where to look for?...

Posted by yannph at Dec 17, 2011 16:33

The import does not take the NKXPROJ file directly but the XML export generated by ETS4 (or the CSV export generated by ETS3).

@Marcus: isn't there some kind of error message when the file format is not understood by the importer ?

Posted by ebariaux at Dec 17, 2011 17:19

It does take the KNXPROJ file. That is the correct file.
I tested the staging version with my file and had no problems.

If something goes wrong there should be log messages.

@Yann: Did you test locally with a snapshot you compiled or the version at http://composer.openremote.org/staging? If you don't mind you can send me your knxproj file and I can debug locally to find the problem.

Posted by mredeker at Dec 17, 2011 17:34

Hi Marcus,
Thank you for your help. I'm using the http://composer.openremote.org/staging
What is strange is that I'm using the same file When I've successfully tested your DEV version, 2 months ago.
I'll send you the project file on your email.
I'm wondering if there is not something weird with the file upload?
If you have access to the server log, I've done upload test between 20.05 and 20.15 CET.
But have no error message, no log.

Regards

Posted by yannph at Dec 18, 2011 19:17

Ok, thanks.
I got the file and will ask Juha for the server logs.

Posted by mredeker at Dec 18, 2011 20:40

When parsing your 0.xml, which is include in the knxproj file, I receive this error:

org.jdom.input.JDOMParseException: Error on line 1: Content is not allowed in prolog.

It looks like ETS4 is producing a different file now after they released some updates.
I will export my project again with the latest ETS4 and try that.

Posted by mredeker at Dec 18, 2011 21:15

I just created a new knxproj from the latest ETS4 and have the same problem.
KNX messed up the xml export or changed something which causes the JDOMParseException.
I will investigate and create a fix.

Posted by mredeker at Dec 18, 2011 21:39

I commited a fix.
Juha will have to integrate into the designer and deploy a new snapshot.

Posted by mredeker at Dec 18, 2011 22:03

I just tried importing an ETS3 project I have and get no results or error message, I have tried importing the ETS3 (*.pr3) file, ETS3d (*.pr4) file and a group address csv file and all fail to do anything after the upload and no error message is displayed.

Am I doing something wrong or is this related to the problem Yann is seeing?

Rich

Posted by kurrazyman at Dec 18, 2011 22:09

thank you Marcus.
It's true that I've used the same KNX project, but a new exported one
That must be the reason. I'll wait for the new release.
Maybe we could you use this case to improve the error handling in the designer?

Regards

Posted by yannph at Dec 19, 2011 08:14

.pr3 and .pr4 files are not supported. The format of those files is not public.
A group address csv file should work. You have to export with ";" as seperator and no header line.
Should look like this:

Gast Ventil Status;0/0/3
Kind1 Ventil Status;0/0/4
Kind2 Ventil Status;0/0/5
Bad Ventil Status;0/0/6
Erdgeschoss Licht;0/1/-
RGB-Trafo Ein/Aus;0/1/0

Posted by mredeker at Dec 19, 2011 08:18

So far the error were only logged at the server side
I just added a fix to also display the exception at the client

Posted by mredeker at Dec 19, 2011 11:15

Thanks Marcus will give this a try, maybe the title bar of the KNX Import dialog should be altered as CSV file implies "," delimited. A short paragraph explaining the import format may be helpful also.

Posted by kurrazyman at Dec 19, 2011 17:12

I will add that to the Howto. It's not mentioned since I added CSV import later.

Posted by mredeker at Dec 19, 2011 18:49

thank you Marcus,
So everything is on Juha hands

Posted by yannph at Dec 19, 2011 19:23

Hi Marcus, that would be great, the project file is not working on my side as well. And because I'm running locally on ETS3 I've tried the CSV too, but wasn't working. Maybe some screenshots on the ETS3 and show the settings we've to apply to make it compatible with the CSV importer ... thanks

Posted by hihi at Dec 20, 2011 12:24

Marcus,

I've just tested the upload of ETS file in the new modeler release (snapshot 20111219 on staging)
and, at least, the file seems to be correctly uploaed and interpreted.
I'll try this evening to import the commands.

Thank you

Posted by yannph at Dec 21, 2011 13:40

Hi Marcus,

Two issues with the ETS Import on staging:

  • I don't have swithc command created. If I selected the command Type "Switch", only "Command On" and "Command Off" are created, but no "Switch" on the designer. If I select the Command Type "Switch Status", only a "Status" Command is created and the Sensor, but not "ON", "Off" & "Switch" commands
  • I've tried to import a KNXPROJ with DPT set in ETS to "1bit" instead of "1.001 on/off". The interpretation of the KNXPROJ File take for ever. I'll send you this sample file to your email.

Some ideas to enhance the KNX import feature:

  • have a "processing" Timer between the 'load' click and the end of the interpretation of the KNXPROJ file. I think something like "Loading" and after "parsing".
  • disabled the group adress from the import list if the group adress is already in the command list of the designer
  • Having a command type to create Switch and Status at the same time. To create a switch and its sensor, we need to import twice the project (or I've missed something). Another solution would be to select the "Switch" command type and propose an additional column "Sensor" (like import?) where the user can click to request to creation of the status/sensor.
  • why not having "default" association between the DPT (if defined) and the Command Type. I.E: DPT1.001 = SWITCH + STATUS, DPT9.001=Custom

My humble opinion
Regards

Posted by yannph at Dec 21, 2011 17:54

Yann,
I will look at your project now to see why one is not imported and the other is.
KNX does allow the same GA for action and status but it's not recommend. A cleaner KNX setup has it's own GA for status. This is why I don't support this. I can see what todo. Maybe adding a combinded command type will do.
--Marcus

Posted by mredeker at Dec 22, 2011 15:18

Hi Pierce,

The current change notes are here:

Designer 2.0 Alpha 9 (2011-12-12 Voldemort)
===========================================

- KNX ETS4 Project Import (Marcus Redeker)
- KNX ETS3 CSV Group Address Import (Marcus Redeker)


Designer 2.0 Alpha SNAPSHOT 2011-12-05 (Diogenes)
=================================================

- Fix for email verification issues (R4861 based on patch in R3133)
- Switch to Spring AOP with @Transactional annotations instead of 
  AspectJ (R4862 - Marcus Redeker)
- Remove dependency to JBoss Archive Browsing lib (R4869)
- Remove dependency to JBoss Serialization lib (R4884)
- Update MySQL drivers to version 5.1.x (R4885)
- Update Java Activation Framework to version 1.1.1 (R4894)
- Update to SUN/Glassfish API versions of Java Persistence API 1.0
  and Java Transaction API 1.1 (R4895)
- Remove dependency to xmlParserAPIs-2.6.2.jar and rely on JDK
  provided implementations for javax.xml.parsers and javax.xml.transform
  instead (R4900)
- Remove regexp validation for HTTP commands in Designer protocol XML 
  definition (R5005)
- Add date/time protocol to Designer which allows configuration of 
  latitude and longitude to calculate sunrise/sunset times and creation
  of date/time events in the controller (R5033 - Marcus Redeker)
- Allow hostname, IPv4 and IPv6 address configuration in Designer
  protocol XML definition for TCP and UDP transports (R5081 - Eric
  Bariaux)
- Add Samsung Smart-TV protocol XML configuration to Designer
  (R5090 - Marcus Redeker)
- Add HomeScenario HSC-40 Z-Wave IP gateway protocol XML configuration
  to Designer (R5144 - Marcus Redeker)
- Handle UTF-8 encoding for panel.xml and controller.xml files 
  generated by Designer (R5170 - Marcus Redeker)
- First iteration (Developer - Alpha) of Domintell protocol XML
  configuration in Designer (R5324 - Eric Bariaux)
- New version of the Russound protocol XML defintion for the Designer
  for re-implemented Russound support in Controller (R5369 - Marcus
  Redeker)

The HEX, HEX-ASCII would be more related to controller releases, not so much about the designer.

However, I haven't seen a code branch that implements this feature yet.

HTH, and happy holidays,

– Juha

Posted by juha at Dec 24, 2011 19:32

Hi Marcus,

I also have a non responding importer ... I'm using CSV file: http://users.telenet.be/pto/test2.csv and I'm using the same syntax as your example ...

any idea what could be wrong?

Thank you in advance!

Posted by hihi at Dec 28, 2011 15:04

It looks like your file is content type "text/plain" and not "text/csv".
I will add that as a supported type and also an error message

Posted by mredeker at Dec 28, 2011 17:11

owkay, maybe a dummy question. How do I change it? I've tried open it in notepad and save it as test5.csv (and type . ENCODING ANSI), I've also tried similar things with Notepad++ and Excel ... without success

Posted by hihi at Dec 30, 2011 12:03

It could have todo with the settings of the apache http or tomcat server the designer is running on. I am not to sure. I used the file the way it was when I saved with ETS.

Maybe saving from Excel would make a difference? Otherwise you will have to wait until Juha releases a new snapshot.

Posted by mredeker at Dec 30, 2011 13:55

Hi
Trying to import soe 40 switches and the 40 related status I've got the follwing error:

Don't know if it's related, but the commands are created, but no Switch and no sensor.

If that can help to debug this great feature
Regards

Posted by yannph at Jan 29, 2012 15:37

I don't think the issue is linked to the KNX import feature but looks like more a memory issue or length size of a request/response due to the number of items.
I've got more than 200 commands and 25 panels.

To reproduce it:

  • open online designer
  • Go to Device
  • Create a new sensor
  • Wait
  • Wait
  • And ....boom, same error

If that can help you.
Juha, since it's no more related to the KNX import, maybe could you create another THREAD with those 2 last messages?

Posted by yannph at Jan 30, 2012 21:35

at least you get a result on the screen, when I do the import of the CSV file, nothing happens ... still don't know what I'm doing wrong, or if the file's syntax is not ok

Posted by hihi at Feb 01, 2012 12:41

Can you email (marcus at openremote dot org) me your CSV file? I can try and debug the problem
Thanks.

Posted by mredeker at Feb 03, 2012 10:28

I was able to debug and the problem was related to Windows and IE/Chrome.
That combination uploaded the file with a different mime/type and my check where I decide if it's ETS3 or ETS4 did not work.
I submitted a patch and the new version of the designer should solve that problem.

Posted by mredeker at Feb 03, 2012 23:54
Document generated by Confluence on Jun 05, 2016 09:30