This page last changed on Sep 24, 2013 by arun3d2002.

Hi, I am new to OpenRemote. Watched couple of videos n youtube. very much impressed to set my Auto-Home. Thought of starting with free version to setup Samsung TV (UE40ES5500).

Stuck in starting OpenRemote.
Steps i did on my Mac OS X Mountain Lion (10.8.5)

1. Downloaded zip file named "OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17".
2. Extracted the file to my Desktop.
3. Opened Terminal
4. Navigated to /bin directory
5. when i typed the command to execute ./openremote.sh run, it says "Permission Denied" - Running this on Administrator account.
6. When i tried the command sudo ./openremote.sh run, it asked for password. When i typed the password, I am getting "command not found" error on Terminal.

Can someone help me please.

(Screenshot attached)


Make the file executable.
"chmod +x openremote.sh"

Posted by mredeker at Sep 25, 2013 08:56

Hi Marcus. Thanks a lot.
Now it starts the Apache server.

SECOND STAGE:
1. I navigated to config.properties file on (/Desktop/OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17/webapps/controller/WEB-INF) and changed the Samsung IP address on it <192.168.1.71> as per document.
2. Then I created an account for OpenRemote Designer and created my own design for iPad with 3 three buttons (mute, volume up and down). using this URL "https://composer.openremote.org/demo/Modeler.jsp"
3. Then I exported the zip file to my desktop (openremote.zip)
4. I extracted the zip file and copied 4 files and pasted into the OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17/webapps/controller/------("Rules" folder with 'modeler_rules.drl' file inside, controller.xml, panel.xml, panels.obj) these are 4 files i copied.
5. And I loaded the "index.html" in the path /Desktop/OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17/webapps/controller/ and entered my credentials to sync with Online Designer (says SYNC COMPLETED)
6. When I execute start the server through Terminal, I am getting this...(screenshot attached)....it says NO RULES FOUND

COULD YOU PLEASE LET ME KNOW AM I DOING IT RIGHT! I have downloaded the app in iPad and added the controller as "http://192.168.1.71:8080/controller/"

I haven't done this step:
I read in some forum do we need to add SamsungTVCommandBuilder in "applicationContext.xml"
/Desktop/OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17/webapps/controller/WEB-INF/classes/
This is were i saw......http://openremote.org/pages/viewpage.action?pageId=19435089

Posted by arun3d2002 at Sep 25, 2013 14:57

You don't need to unzip and copy files. This is done by the online sync.
The log looks fine. Do you see your design when you start the iPad app?

Posted by mredeker at Sep 25, 2013 18:49

Oh ok. No i couldn't see my design and cant able to add my controller in iPad. Tried adding the controller as http://192.168.1.71:8080/controller

THIS IS WHAT I TRIED:
1. Freshly I downloaded the openController from the site.
2. I changed my SamsungTV IP address <192.168.1.71> in config.properties file
3. My design is in this window - https://composer.openremote.org/demo/Modeler.jsp
4. Then I loaded index.html file to sync the online design - Is there any URL to navigate directly to the page to sysnc the design
5. After got confirmation "SYNC COMPLETED"
6. Start the server on Terminal

7. Loaded the OpenRemote app on my iPad, switched ON "Auto Discovery" - can't see my controller
8. Added manually, but getting RED DENIED icon next to the controller URL

Is my STEP 4 is correct?

COULD YOU PLEASE EXPLAIN STEP BY STEP, PLEASE.

Posted by arun3d2002 at Sep 25, 2013 20:52

Your steps are all correct. But it does not find controller.xml which should be there if you sync and it says sync complete.

Posted by mredeker at Sep 25, 2013 21:58

I loaded the "index.html"typed in my credentials with online radio button selected and submitted. Got a message Sync Completed, but still says could not find controller.xml. Am I doing anything wrong....I cant proceed further. Please help

Posted by arun3d2002 at Sep 25, 2013 22:56

If you hit the save button in the online designer and look at the exported openremote.zip file, does that include a controller.xml file?

Posted by mredeker at Sep 26, 2013 08:30

Yes. It has controller.xml file with 2 more files (panel.xml & panels.obj) and 1 "rules" folder with 'modeler_rules.drl' (unix executable file).

Posted by arun3d2002 at Sep 26, 2013 09:05

After the sync the panel.xml and controller.xml should also show up in the "OpenRemote-Controller/webapps/controller" folder. Is that the case?

Posted by mredeker at Sep 26, 2013 09:12

No its not. None of those files are not in "OpenRemote-Controller/webapps/controller" folder.

THIS IS HOW I SYNC MY DESIGN

Posted by arun3d2002 at Sep 26, 2013 09:58

That would assume that there is a problem with permissions or something else.
Do you see any error in one of the files in the log folder?

Posted by mredeker at Sep 26, 2013 11:12

I navigated to logs folder. On the boot.log file Error says "Could not found controller definition".

Posted by arun3d2002 at Sep 26, 2013 13:00

Hello Arun,

The homescreen you have posted does not appear to be that of the SNAPSHOT-06-17 controller binary. There seems to be some confusion of which version you are running – which also means the controller files are potentially getting saved to a different location in your file system.

The SNAPSHOT-2013-06-17 homescreen should not include account linking information you are showing in your screenshot above and the 2013-06-17 binary will report 'snapshot' as its version in the bottom right corner.

Posted by juha at Sep 26, 2013 13:21

Hello Juha,

Sorry to trouble you guys. I am not a developer. I really appreciate your patients for helping me.

Could me tell me how to do this.

The controller version i downloaded is 2.1.0, whereas on the Terminal it says Version 2.0 -----Is that what you mean.

If you guys can tell me exactly what i need to do.

Please thanks.

How to sync online designer? which URL? I synced the account via index.html in ../webapps/controller/ folder.

Posted by arun3d2002 at Sep 26, 2013 13:52

Hi Arun,

What I mean was that do you have multiple versions of OpenRemote installed on your system? I see OpenRemote 2013-06-07 and openremote and openremote 2 folders at least.

Because the screenshot you posted didn't look to me like it was OpenRemote 2013-06-07. Which means you may be looking for the installed files in the wrong folder?

If you do a spotlight search for controller.xml from the top right corner on your Mac, what does it find?

Posted by juha at Oct 02, 2013 11:55
Document generated by Confluence on Jun 05, 2016 09:31