This page last changed on Mar 29, 2015 by careycj0219.

Hi all,

I'm struggling to understand what I'm doing wrong here. I've dug around quite a bit, but I'm obviously missing something.

I'm trying to run a test with OR to send a command over HTTP to a server on my LAN. I do not have any z-wave or similar hardware devices, as I'm trying to test OR functionality with IP and HTTP commands first. I receive an error related to my serial port, which I don't quite understand, since I didn't think this would rely on a connection through a serial port.

I have a command defined in OR Designer as:
Protocol: HTTP
URL: <IP ADDRESS>:<PORT>/<COMMAND>
HTTP Method: GET
(everything else is blank)

I have the OR controller running on my linux server (same server I'm trying to send the command to). I've assigned this command to a button. When I press once, nothing happens. On pressing again, I get a port in use error (below).

INFO: Server startup in 2253 ms
Experimental: JNI_OnLoad called.
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.1-7
RXTX Warning: Removing stale lock file. /var/lock/LCK..ttyS0
ERROR HTTP\-Thread\-6: com.jpeterson.x10.GatewayException: Request com port /dev/ttyS0 in use (CM11A).

If I go to a web browser and execute "<IP ADDRESS>:<PORT>/<COMMAND>", everything works fine.

Any help is greatly appreciated, since it seems I'm missing something fundamental here.

Thanks,
Carey

Did you read this: http://www.openremote.org/display/docs/OpenRemote+2.0+How+To+-+HTTP+Protocol

Posted by pz1 at Mar 29, 2015 19:48

Yes. My configuration seems to me ok according to that page.

Posted by careycj0219 at Mar 29, 2015 20:02

That error has nothing todo with HTTP.
It's the serial port /dev/ttyS0 which cannot be used. Your config seems to include some X10 stuff.

Posted by mredeker at Mar 30, 2015 00:04

I've looked in config.properties, and the only thing I see related to x10 is "com.port=/dev/ttyS0". I've tried changing to ttyS1 and so on, and I've tried commenting it out all together. Neither seems to fix things.

I have not modified the configuration files from install. Is there somewhere I need to disable x10?

Posted by careycj0219 at Mar 30, 2015 02:21

Do you use X10 at all and have some X10 commands?
How about your controller properties in the designer?

Posted by mredeker at Mar 30, 2015 09:26

Everything seems to be working now. It looks like I have another service using port 8080, so I changed the port number. I had tried this before with no luck, but this time it seemed to fix things.

Also, I had to delete and recreate the button I was using inside the designer. For some reason I was getting no response until I did this.

Thanks for the help!

Posted by careycj0219 at Mar 30, 2015 13:26
Document generated by Confluence on Jun 05, 2016 09:33