This page last changed on Feb 24, 2014 by placemaster.

I have had open remote running on my synology DS1813+ for a long time. This was without a problem.
Since last week I have updated to the Beta 5.0 of Synology. After a complete restart of all the knx related stuff it worked again.
Yesterdy there was a patch of the Beta 5.0 and I just installed it. Now my OR is not working anymore.
I have restarted every thing already but it doesn't work.

Below you will find my log.

I do see that it is resolving the knx interface.
After that I don't know what is happening.

Any help is welcome.

INFO 2014-02-24 19:47:05,870 (KNX): KNX Connection manager resolving local host IP addresses...
INFO 2014-02-24 19:47:05,871 (KNX): Found candidate NIC: name:bond0 (bond0)
INFO 2014-02-24 19:47:05,871 (KNX): Skipped IPv6 address (not supported by KNX) /fe80:0:0:0:211:32ff:fe1e:28a1%6
INFO 2014-02-24 19:47:05,872 (KNX): Added candidate IP address to set - /10.10.10.10
INFO 2014-02-24 19:47:05,872 (KNX): Skipping loopback interface: name:lo (lo)
INFO 2014-02-24 19:47:05,879 (KNX): Found a KNX IP interface at /10.10.10.12:3671
INFO 2014-02-24 19:47:05,879 (KNX): Connection created for KNX IP interface at /10.10.10.12:3671
INFO 2014-02-24 19:47:05,882 (KNX): KNX-IP socket listener IOException
java.net.SocketException: Socket closed
at java.net.PlainDatagramSocketImpl.receive0(Native Method)
at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
at java.net.DatagramSocket.receive(DatagramSocket.java:786)
at org.openremote.controller.protocol.bus.DatagramSocketPhysicalBus.receive(DatagramSocketPhysicalBus.java:38)
at org.openremote.controller.protocol.knx.ip.IpProcessor$PhysicalBusListener.run(IpProcessor.java:79)
WARN 2014-02-24 19:47:05,883 (KNX): KNX-IP socket listener stopped
WARN 2014-02-24 19:47:05,883 (KNX): Could not connect
org.openremote.controller.protocol.knx.ConnectionException: Connect failed
at org.openremote.controller.protocol.knx.KNXIpConnectionManager$KNXConnectionImpl.connect(KNXIpConnectionManager.java:706)
at org.openremote.controller.protocol.knx.KNXIpConnectionManager.getConnection(KNXIpConnectionManager.java:224)
at org.openremote.controller.protocol.knx.KNXIpConnectionManager$ConnectionTask.run(KNXIpConnectionManager.java:980)
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)
Caused by: org.openremote.controller.protocol.knx.ip.KnxIpException: Connect failed : 36
at org.openremote.controller.protocol.knx.ip.IpTunnelClient.connect(IpTunnelClient.java:136)
at org.openremote.controller.protocol.knx.KNXIpConnectionManager$KNXConnectionImpl.connect(KNXIpConnectionManager.java:704)
... 4 more

"Connect failed: 36" is an error from the KNX IP Interface. You could try and restart that one. Maybe it helps.

Posted by mredeker at Feb 25, 2014 08:25

The issue was with installing the newer version of the Synology DSM 5.0 I had to reinstall java as well.
I did not remember that java version 7 was not supported.
So I removed java version 7 and installed Java SE for Embedded 6u38 (ejre-1_6_0_38-fcs-b05-linux-i586-headless-13_nov_2012). You can find it here : http://www.oracle.com/technetwork/java/embedded/downloads/javase/default-1934076.html

I am using a Synology DS1813+

After restart of openremote it all worked.

Posted by placemaster at Feb 26, 2014 10:35
Document generated by Confluence on Jun 05, 2016 09:37