This page last changed on Sep 26, 2013 by peterchrisben.

Hi Guys,
has anybody else trouble with landscape view on iOS 7? Landscape view is not visible on my iPhone 5 and iPad 2 in the openremote-app. The OR-App stay in
portrait after rotation. It work defenetly before upgrade to iOS 7. Only the settings-page is in Landscape, when i turn the iPad before an go into the settings. It rotate neither when i am
allready in the settings.
Regards,
Chris

Yes, it seems that rotation is not taken into account in the application.

If you have a screen design with only 1 orientation, this should not be an issue though, as it'll always display that one orientation.
For the settings screen, what I've seen is that it'll stay in the orientation the device was in when the application was launched.

The iOS console still has code dating from iOS 3, it's clear a cleanup is required but this is not a small undertaking, mainly with iOS 7 support. So this might take some time...

Posted by ebariaux at Sep 27, 2013 10:13

It not only doesn't rotate anymore on my iPad, some 'switches' flikker between the 'on' picture and the 'off' picture.

I need to get my timing right when i want to turn off a light...

I wish i never upgraded to ios7...

Posted by icefluffy at Oct 07, 2013 19:15

Haven't seen the switch issue yet. I'll try to reproduce that one too.

As far as time / priorities permit, I'm working on updating the iOS console code so it works OK with current SDK, but it might still be quit a bit until I can release a new version to Apple.

Posted by ebariaux at Oct 08, 2013 09:49

My openremote is running on a synology nas ds213+
Stopping openremote in package center and then restarting it made the flikkering of my switches between the on and off pictures stop.

Although it started when upgrading my ipad to ios 7 it is gone after restarting the package. Thank you for all your help

Looking forward to the update of the openremote client to ios7

Greetz to this awesome community!.

Posted by icefluffy at Oct 08, 2013 18:48

My openremote is running on a synology nas ds213+
Stopping openremote in package center and then restarting it made the flikkering of my switches between the on and off pictures stop.

Although it started when upgrading my ipad to ios 7 it is gone after restarting the package. Thank you for all your help

Looking forward to the update of the openremote client to ios7

Greetz to this awesome community!.

Posted by icefluffy at Oct 08, 2013 18:48

Hi Eric,
do you have any new information about the app-update release?!
regards,
Chris

Posted by peterchrisben at Dec 06, 2013 03:26

I'm working (on and off between other tasks) on a major rework of the iOS code base but have no date yet on when something will be ready.
I'll post in the forums anyway when we submit to Apple.

Posted by ebariaux at Dec 06, 2013 08:40

Hi Eric,
I have the same problem with my iPadMini, after ios upgrade to 7, (now is 7.0.4),
I can use only portrait screens.

Thanks for any suggestions.

Posted by mb at Jan 18, 2014 08:35

Hi Maurizio,

Be aware that you can still use landscape screens as long as you mark them as landscape only in your designer. I don't now if this helps your use case, but it might be good to know.

@Eric, any news on the iOS code base your working on?

Posted by tjoek at Jan 18, 2014 17:12

Working on it on and off, nothing ready for release yet

Posted by ebariaux at Jan 20, 2014 07:58

Hi,

I am experiencing the same issues as listed above.
Are we getting close to a new release? Do you have an estimate for when you see the new release?
Also will the new release "fill" the iPhone 5 screen completely? Now the screen is only
the size of the older generation iPhones. Customs screens in the designer does not fix the issue.
I have read somewhere on the forum its because of the app and the support...?

Posted by istian at Feb 03, 2014 18:26

Still working on it and don't have a date.

It'll take the 4" screen size into account and you'll be able to design 320x568 screens in the designer.
Full retina support will come later.

Posted by ebariaux at Feb 07, 2014 13:40

+1 for added priority to iOS 7.

As a new user since last night, this was one of the first issues I ran into. The other issues were around Chrome failing to save in Designer after some period of use (Safari doesn't seem to have the same issue), and some initial difficulty digesting the documentation-- still working on that one, but the forums are very helpful.

Posted by okachobi at Apr 06, 2014 15:21

Hello again,
any new information for the update? My complete openremote stuff is unuseable since the update to ios7.
8 month are gone now....
Regards,
Chris

Posted by peterchrisben at May 24, 2014 14:00

Me again....

are you waiting for iOS 8?

Posted by peterchrisben at Jul 01, 2014 11:38

This is community work. So if no one has the time available, it is either do it yourself, or be patient

Posted by pz1 at Jul 01, 2014 13:00
Document generated by Confluence on Jun 05, 2016 09:42