This page last changed on Feb 17, 2015 by nfettinger.

I am unable to get a debug device listing of nodes attached to my Aeon Labs Z-stick. Following many install instructions and the instructions here: Discover Controller Z-wave Devices, I have tried this on multiple machines and Operating Systems, but still I get no output.

Machines used:
Ubuntu 14.04 x64
Ubuntu 14.10 x86
Windows 7 x64

Versions used:
OpenRemote-Controller-2.0.0
OpenRemote-Controller-2.1.0
OpenRemote-Controller-2.1.1

Hardware:
Aeon Labs Z-Stick S2 Model: DSA002203-ZWUS
5 Nodes currently attached (Verified using other software)

I have already gone through all posts for common problems such as librxtx versions, I have tried multiple JDK versions of Java, I have tried multiple versions of openremote (including the new zwave.jar), and I am to the point where I believe it must be a configuration issue. Here is what I see in my zwave.log and zwave-debug.log:

INFO 2015-02-17 10:48:09,228 (Z-Wave): 

--------------------------------------------------------------------

  OpenRemote Z-Wave protocol version : '2.0.0'

--------------------------------------------------------------------

From this, I can tell the log is created successfully but the controller doesn't seem to realize the zstick exists. I assume this because no thread is started for Zwave.
Here is my configuration.xml for the Windows machine. The switch was added to try to force something to be printed, didn't work.

<?xml version="1.0" encoding="UTF-8"?>
<openremote xmlns="http://www.openremote.org" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.openremote.org http://www.openremote.org/schemas/controller.xsd">
  <components>
    <switch id="12">
      <on />
      <off />
    </switch>
  </components>
  <sensors />
  <commands />
  <config>
    <property name="controller.roundrobin.multicast.port" value="10000" />
    <property name="controller.roundrobin.tcpserver.port" value="20000" />
    <property name="controller.groupname" value="floor20" />
    <property name="multicast.port" value="3333" />
    <property name="controller.groupmember.autodetect.on" value="true" />
    <property name="amx_ni.port" value="50000" />
    <property name="zwave.comPort" value="COM5" />
    <property name="copy.lircd.conf.on" value="true" />
    <property name="irsend.path" value="/usr/local/bin/irsend" />
    <property name="controller.applicationname" value="controller" />
    <property name="multicast.address" value="224.0.1.100" />
    <property name="Macro.IR.Execution.Delay" value="500" />
    <property name="controller.roundrobin.multicast.address" value="224.0.1.200" />
    <property name="zwave.pad.port" value="7876" />
    <property name="protocol.zwave.classname" value="org.openremote.controller.protocol.zwave.ZWaveCommandBuilder" />
    <property name="lutron_homeworks.password" value="openremote" />
    <property name="lagarto_network.broadcast" value="tcp://127.0.0.1:5001" />
    <property name="lircd.conf.path" value="/etc/lircd.conf" />
    <property name="lutron_homeworks.port" value="23" />
    <property name="lutron_homeworks.address" value="192.168.1.1" />
    <property name="lutron_homeworks.username" value="openremote" />
    <property name="webapp.port" value="8080" />
    <property name="zwave.pad.host" value="localhost" />
    <property name="zwave.commLayer" value="RXTX" />
    <property name="resource.upload.enable" value="true" />
    <property name="amx_ni.address" value="192.168.1.1" />
    <property name="protocol.vera.classname" value="org.openremote.controller.protocol.vera.VeraCommandBuilder" />
    <property name="vera.address" value="8.8.8.8" />
    <property name="enocean.commLayer" value="" />
    <property name="enocean.serialProtocol" value="ESP3" />
    <property name="enocean.comPort" value="" />
    <property name="domintell.port" value="17481" />
    <property name="domintell.address" value="192.168.1.1" />
  </config>
</openremote>

Is there an example controller.xml file that I could use? If I could get this to work, I will be upgrading to the Professional version since I plan to have more than 10 nodes. However, I don't want to waste the money if I end up needing to purchase another software platform such as HS3. Are there any trial versions of Pro available?

Thanks to this reply, I have solved this problem. Please update the guides that a sensor is needed.

Posted by nfettinger at Feb 19, 2015 02:05
Document generated by Confluence on Jun 05, 2016 09:37