This page last changed on Jun 21, 2013 by mcfanda.

Setup: raspberry pi with zwave.me controller.

Using controller version 2.0.2 I had setup several HTTP commands of this form:

http://192.168.0.109:8083/ZWaveAPI/Run/devices%5B3%5D.instances%5B0%5D.SensorBinary.data.level.value

and everything worked. Then I upgraded OR controller to OpenRemote Controller 2.1.0 Developer Release and the commands no longer worked. The error on the z-way side was:

Executing script: zway.devices%5B3%5D.instances%5B0%5D.SensorBinary.data.level.value
JavaScript compilation error: Uncaught SyntaxError: Unexpected token ILLEGAL

The solution was to change all the commands %5B with "[" and %5D in "]".

I hope the encoding-decoding will remain the same in next versions because the changing of the commands it is very time consuming. Or maybe I'm overlooking some issue that would not generate the errors no matter what chars - %5B or [ - one uses.

cheers
marcello

OpenRemote 2.0 How To - Z-Wave with Razberry

Posted by pz1 at Jun 23, 2013 08:49

Thanks, I knew the link. I just wanted to signal that from ORcontroller 2.0.2 to 2.1.0 the "[" should be used instead of the %5B (which gave me a lot of headache )

Posted by mcfanda at Jun 23, 2013 12:00

Thanks for reporting the issue. Had not realized we introduced an incompatibility between the two versions. Obviously we should not. I'll check if anything can be done at this point anymore.

Posted by juha at Jun 23, 2013 12:09
Document generated by Confluence on Jun 05, 2016 09:42