This page last changed on Dec 11, 2015 by ebariaux.

A new Pro release is now available for Pro Users.
Version 1.4.0 adds support for the Domintell protocol, includes some reworks on the server side to prepare for future upgrades and brings an updated image for eBox users.

Controller 1.4.0

New features:
  • ORCJAVA-253 - Add Domintell protocol support
  • ORCJAVA-443 - Parameterize common Beehive connection parameters in config.properties
  • ORCJAVA-495 - Do not encode password in communication with CCS/DDS
  • ORCJAVA-498 - Upgrade flexjson library to version 3.2
  • ORCJAVA-499 - Remove warnings when compiling under JDK7/8
  • ORCJAVA-501 - Support remote command to trigger online sync
  • ORCJAVA-503 - Never send md5 encoded password to backend
  • ORCJAVA-504 - Start the BeehiveCommandCheckService thread even if no configuration is loaded
Bug fixes:
  • ORCJAVA-456 - Re-connection issues with AMX protocol
  • ORCJAVA-496 - BeehiveCommandCheckService does not properly decode response received from Ack
  • ORCJAVA-497 - Multiple issues in BeehiveCommandCheckServiceTest
  • ORCJAVA-505 - Potential NPE in BeehiveCommandCheckService

eBox image 1.4.0

It looks linke openremote.sh has an error in line 226: echo " $1 = $

Unknown macro: {!1}
"

Posted by jever1966 at Dec 12, 2015 07:54

I copied the image through the OR designer to the sd card of my ebox.
Ip number is the same, webmin has been upgraded
I saved my latest design through designer, open de webi'face for upload to the controller, logged in but the 'hourglass' or whatever you called it doesn't stop turning when I synchronise.
My mobile app's do not find the controller (although ip number is right)
I suspect there is something wrong with the image, maybe the controller is not started at launch or something like that.
trouble is I do not have the forelast version of the img, and cannot restore it.
So my installation is broken...
Can someone look into this?

Best regards,

Olivier

Posted by oliviertoebosch at Dec 13, 2015 10:41

There seems to be an issue when OR controller is run from yasjw, which is the default setup on the eBox.
We'll look into it in more details.
For now, you could log into the eBox and stop yajsw, then restart OR manually

/etc/init.d/yajsw stop
cd /opt/OpenRemote-Controller/bin
sudo -u tomcat ./openremote.sh start
Posted by ebariaux at Dec 13, 2015 11:40

Thank you Eric. did extactly what is written here, and indeed no errors at startup anymore.
Next issue: zwave does not function. 'send request error, command not found' on the clients (android in my case) when commanding a zwave device

Posted by oliviertoebosch at Dec 13, 2015 12:39

You need to replace the zwave.jar with the version that can be found on the Z-Wave 2.0 forums thread.
We don't bundle it with the Controller (zip or eBox image) distribution (I think there are some licensing implications behind, don't remember exactly).

Posted by ebariaux at Dec 13, 2015 14:16

Eric, again I did exactly what you said. Searched througout the forum and found this link http://download.openremote.org/free/zwave (easy for the other readers ), found on this page: http://www.openremote.org/display/docs/OpenRemote+2.0+How+To+-+Z-Wave
uploaded it to the controller (used the new file manager interface from webmin), restarted the openremote with the same command but still have an error (command not found).
Is there another zwave.jar?

best regards,

Olivier

Posted by oliviertoebosch at Dec 13, 2015 19:57

still stuck here...is there anyone who could share a link to the old ebox image? If I cannot fix this issue, I prefer to downgrade. It's against my principles, but my system is down, which is worser!
thx
Olivier

Posted by oliviertoebosch at Dec 16, 2015 11:32

I'll send you the link, on the other hand Z-Wave has not changed to I'm curious why this is failing. Do you have any logs you could send me ?

Posted by ebariaux at Dec 17, 2015 07:20

Took a quick look, script is working fine on a Mac (dev machine) but not on the eBox. I'll do some tests there and on other linux flavors.

Posted by ebariaux at Dec 17, 2015 07:21

I do have problems with Pro 1.4 on Synology DS212+. I did have to upgrade from 1.3 because after I synchronised a small change in the UI, My display was totaly messed up i.e. they were no longer updated even though it were similar devices.
So I stopped the OR service and copied the Zip as usual to my machine. The service did not start from the Synology plugin manager. Nothing in the logs either. I tried the following two manual starts:

DS212> ./openremote.sh run
openremote.sh: line 226: syntax error: bad substitution

Line 226 is the last in the following code block:

##
# Prints a variable name and its value. Mostly used for printing external environment
# values to communicate settings on the standard output stream.
#
# $1 is expected to contain the variable name to print.
##
printVariable()
{
  if [ -z "${PRINTING_VARIABLES}" ] ; then
    PRINTING_VARIABLES="true"

    echo ""
    echo "Configured Variable Values:"
  fi

  echo "  $1 = ${!1}"
DS212> ./openremote.sh debug
The JAVA_HOME environment variable is not defined correctly
This environment variable is needed to run this program
NB: JAVA_HOME should point to a JDK not a JRE

env command result:

SSH_CLIENT=xxx.xxx.xxx.xxx 52989 22
MAIL=/var/mail/root
USER=root
OLDPWD=/volume1/l_apps/OpenRemote
HOME=/root
SSH_TTY=/dev/pts/1
PAGER=more
LOGNAME=root
TERM=xterm
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin:/volume1/@appstore/java7/jre/bin
LANG=en_US.utf8
SHELL=/bin/ash
CLASSPATH=.:/volume1/@appstore/java7/jre/lib
JAVA_HOME=/volume1/@appstore/java7/jre
PWD=/volume1/l_apps/OpenRemote/bin
SSH_CONNECTION=192.168.1.23 52989 xxx.xxx.xxx.xxx 22
PGDATA=/var/service/pgsql
TZ=CET-1CEST,M3.5.0,M10.5.0/3

All previous versions since 1.x did work well with these settings

Update 14:19 On windows 7 PC this 1.4 runs as expected.

Posted by pz1 at Dec 20, 2015 11:30

I'm not running the newest pro controller on my Synology yet, as this is against my life motto "If it does not break, don't fix it", but a small difference which I have is

CLASSPATH=.:/var/packages/JavaManager/target/Java/jre/lib
JAVA_HOME=/var/packages/JavaManager/target/Java/jre

However, it should not make the difference IMHO.

Posted by aktur at Dec 21, 2015 12:50

Thanks for looking into this. I only changed, because my system seemed to be mixed up.
So since the online designer is 1.4 now, I decided to upgrade the controller to 1.4 as well.

update 20151211: Did a complete re-install; first free version with "Patters" installer, which worked fine. Next stopped service and copied all Pro 1.4 files over the free version. Result the same errors.

update 20151211-2: Got Pro 1.1.0 running, but lots of errors because of JRE7.

update 20151230: Got Pro 1.3 running. Initially I got the same erors, but these were cleared after I removed a http command to the TTN LoraWan server. For me 1.3 controller seems to work well with designer 1.4.

Posted by pz1 at Dec 21, 2015 14:50

Controller 1.4 still fails on Synology DS212+

Posted by pz1 at Jan 01, 2016 14:16
Document generated by Confluence on Jun 05, 2016 09:33