This page last changed on May 03, 2013 by garderhagen.

Hi.

I have made a simple console that now works on my iPhone. However accessing this console while being connected to 3G does not work.
I have made needed configurations for making the controller available on internet, and i can access it from my iPhone while being connected to public Wlan, but 3g does not work.

If i open openremote app while connected to 3g, it only closes
If i switch to 3G wile having the app open, i will get a message saying "Can't download image from Server, there is no network"

I googled this error message and found a code file on SVN from the iPhone app. To me it looks like there is a function named "checkWhetherNetworkAvailible" that throws this exception if it fails.

Could anyone comment on this ? Is it by design that the iPhone app only supports Wifi connection ?
If so, are there any plans for removing this limitation ?
Are there any workarounds ?

Thank you
Best regards
Bjørn Tore

It's not a design decision and I thought it had been working at some point.
The connection code still needs some review.

I'll do some more testing with 3G when reviewing that code, but no promise on when I'll get to that.
If somebody with iOS dev experience wants to check it, just let me know and I'll check the status of the work on that bit of code.

Posted by ebariaux at May 07, 2013 12:01

Hi Bjørn
I have the same problem. Did you manage to solve this problem?

Posted by batmankuhn at Apr 10, 2014 08:18
Document generated by Confluence on Jun 05, 2016 09:42