This page last changed on Apr 15, 2015 by jsanjur.

Hi all,

Hopefully you will be able to assist me.

I installed OR on a Raspberry Pi.

To start the controller i used ./openremote.sh run and it works fine with no problem.

I start having problems when i try to set it up to start automatically.

Ive tried the two methods from the installation guide for Pi

First - Editing the rc.local file
cd /home/pi/OpenRemote-Controller-2.1.0/bin/
./openremote.sh start

Second - placing a script on the init.d folder and using the update-rc.d (script below)
#!/bin/sh

      1. BEGIN INIT INFO
  1. Provides: openremote
  2. Required-Start: $remote_fs $syslog
  3. Required-Stop: $remote_fs $syslog
  4. Default-Start: 2 3 4 5
  5. Default-Stop: 0 1 6
  6. Short-Description: Start daemon at boot time
  7. Description: Enable service provided by daemon.
      1. END INIT INFO

cd /home/pi/OpenRemote-Controller-2.1.0/bin # Modify this line to your OpenRemote Controller installation path

case "$1" in

stop)
echo "Stopping OpenRemote Controller..."
sudo /home/pi/OpenRemote-Controller-2.1.0/bin/openremote.sh stop > /dev/null 2>&1 &
;;

start)

  1. start OpenRemote in background mode
    sudo /home/pi/OpenRemote-Controller-2.1.0/bin/openremote.sh start > /dev/null 2>&1 &
    echo "OpenRemote Controller started..."
    ;;

restart)
$0 stop
sleep 5
$0 start
;;
*)
echo "usage: $0

Unknown macro: { start | stop | restart}
" >&2
exit 1
;;

esac

With BOTH methods, the controller starts when the raspberry boots up BUT after about 30 seconds, it just stop responding. Ive tried with both methods adding sudo but still the same. If i do it manually then it works fine.

What could the problem be or how can i take a look at what might be the problem?

Thanks

Hi Juan,

does your openremote process still stays in memory but stops responding or does it quit completely?

For me a crontab entry works fine:

@reboot    /home/openremote/controller_start.sh

and in controller_start.sh I have

#!/bin/sh
cd /opt/OpenRemote-Controller/bin; sh openremote.sh start
Posted by aktur at Apr 15, 2015 10:04

Its weird how its acting.

When i start the RPi, i run
ps -axu | grep -i openremote and i get this:
root 2041 88.3 4.0 625368 38608 ? Sl 19:54 0:15 /usr/bin/java -Dcatalina.home=/home/pi/OpenRemote-Controller-2.1.0 -Dcatalina.base=/home/pi/OpenRemote-Controller-2.1.0 -Djava.io.tmpdir=/home/pi/OpenRemote-Controller-2.1.0/temp -Dtomcat.server.console.log.level=OFF -Dopenremote.controller.startup.log.level=INFO -Dopenremote.controller.console.threshold=OFF -Djava.library.path=/home/pi/OpenRemot -Controller-2.1.0/webapps/controller/WEB-INF/lib/native -Djava.util.logging.config.file=/home/pi/OpenRemote-Controller-2.1.0/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -classpath :/home/pi/OpenRemote-Controller-2.1.0/bin/tomcat/bootstrap.jar org.apache.catalina.startup.Bootstrap start
pi 2184 0.0 0.1 3552 1792 pts/0 S+ 19:54 0:00 grep --color=auto -i openremote

I go to the controller page http://ip:8080/controller and the page is up ... if i refresh a couple of times with F5... the page is still there BUT as soon as i try to log in to sync the controller then page goes down.

ps... i tried the contrab, with the pi and root user and its not working,not even starting the service

Thanks

Posted by jsanjur at Apr 15, 2015 21:13

What do the logs say, not sure how yours is setup but when i look at my tomcat logs there is usually something crashing it.

So try and find the catalina.out file and it should show your error. It could be an out of memory issue.

Posted by glennl at Apr 16, 2015 02:13
Document generated by Confluence on Jun 05, 2016 09:33