This page last changed on Feb 25, 2014 by nklerk.

Hi,

I am running Openremote on my Synology and was playing with it to get my philips HUE turned on and off. but unfortunatly i am stuck with the most simple instruction.

I created some simple commands.

##dev.log

2014-02-25 21:51:55,094 DEBUG [Controller Definition File Watcher for Default Deployer]: Created object model for Command( ID = 100, Type = http, Properties : {workload={"on":false}, name=Group1Off, method=PUT, url=http://10.2.1.10/api/NDKhueapps/groups/0/action/}).
2014-02-25 21:51:55,095 DEBUG [Controller Definition File Watcher for Default Deployer]: Created object model for Command( ID = 101, Type = http, Properties : {workload={"on":true}, name=Group1On, method=PUT, url=http://10.2.1.10/api/NDKhueapps/groups/0/action}).
2014-02-25 21:51:55,095 DEBUG [Controller Definition File Watcher for Default Deployer]: Created object model for Command( ID = 102, Type = http, Properties : {workload={"on":true}, name=L1On, method=PUT, url=http://10.2.1.10/api/NDKhueapps/lights/1/state}).
2014-02-25 21:51:55,096 DEBUG [Controller Definition File Watcher for Default Deployer]: Created object model for Command( ID = 103, Type = http, Properties : {workload={"on":false}, name=L1Off, method=PUT, url=http://10.2.1.10/api/NDKhueapps/lights/1/state})

Unfortunatly they dont work and i am stuck at it.

##dev.log

2014-02-25 21:52:25,887 INFO [HTTP-Thread-2]: received message: [{"error":{"type":3,"address":"/groups/0/action","description":"resource, /groups/0/action, not available"}}]
2014-02-25 21:52:26,912 INFO [HTTP-Thread-2]: received message: [{"error":{"type":3,"address":"/groups/0/action","description":"resource, /groups/0/action, not available"}}]
2014-02-25 21:52:29,354 INFO [HTTP-Thread-2]: received message: [{"error":{"type":3,"address":"/lights/1/state","description":"resource, /lights/1/state, not available"}}]
2014-02-25 21:52:30,315 INFO [HTTP-Thread-2]: received message: [{"error":{"type":3,"address":"/lights/1/state","description":"resource, /lights/1/state, not available"}}]

Curl works just fine BTW:

curl -X PUT -d "{\"on\": false}" http://10.2.1.10/api/NDKhueapps/groups/0/action
[{"success":{"/groups/0/action/on":false}}]
curl -X PUT -d "{\"on\": false}" http://10.2.1.10/api/NDKhueapps/lights/1/state
[{"success":{"/lights/1/state/on":false}}]

Someone knows what i am missing?

Did you read this: OpenRemote 2.0 How To - Philips Hue
I don't see any issue at the moment.

Posted by mredeker at Feb 26, 2014 08:23

Thanks!

I saw the post, but didnt see the banner explaining i needed the patch

It is working like a charm now.

Posted by nklerk at Feb 26, 2014 19:54

Hi,

Could you please have a look at this post (go to the bottom) http://www.openremote.org/pages/viewpage.action?pageId=21857719, I saw the post that the banner explaining i needed the patch.
But could you explain a little bit how to merge the patch into my source code...

Thank-you

Posted by wangjia at Nov 24, 2014 15:20
Document generated by Confluence on Jun 05, 2016 09:37