This page last changed on Jul 07, 2011 by jammastercd.

I'm a relative noob to OpenRemote and not a Java/web developer. However, I'm really liking what OR has to offer. I recently added the WebConsole to my OR installation and can access it at http://<ip-address>:8080/webconsole. However, when I enter this address into my web browser, I receive an error stating that the panel.xml is not found. The settings for the Web Console show that auto discovery is on, and the controller is successfully found. I don't see any panels, though. So far, I have built a test panel using Android, which I can successfully see on my Android G2. My question is what do I need to do to see a panel in the Web Console? Do I need to create a custom panel in the Online Designer? Or do I need to do something other than sync with Online Designer in the controller?

Your thoughts and advice are appreciated!

The sync should have been sufficient. If the Android panel works then obviously the panel.xml is in place, not sure why the web console would not find it.

If you can find any more info to share that might help debug the issue.

Posted by juha at Jul 10, 2011 09:54

In what directory would you expect the panel.xml file? I did a file find search and only found a reference to 'panel' in the following directory (aside from some non-OR directories):

/opt/openremote/OpenRemote-Controller-2.0.0_SNAPSHOT_20110611/webapps/webconsole/resources/images/default/panel

As you can see, I installed OR in a directory I created named /opt/openremote.

Posted by jammastercd at Jul 11, 2011 02:48

You should find the panel.xml in /opt/openremote/OpenRemote-Controller-2.0.0_SNAPSHOT_20110611/webapps/controller/
After a sync with the designer the controller puts the panel.xml in it's own folder.

Posted by mredeker at Jul 11, 2011 08:10

I do see the panel.xml file in the directory you suggested. For some reason, it's not being recognized. I did reinstall OR recently and deleted the old directories, which were in a usr location. Is it possible that the new installation is trying to look for the panel.xml in the previous location? If so, is there a way for me to change a configuration to look in the current location? Or should I consider removing the new installation and reinstalling again?

Also, I tried my Android phone again, and it is receiving the same panel.xml not found error. I must've last tried before removing the previous installation.

Sorry for the confusion, and thanks for the help!

Posted by jammastercd at Jul 12, 2011 03:08

The panel.xml is always uploaded from the controller into the controller directory which is underneath the webapps folder of the used tomcat. Maybe you still had a tomcat running from your old installation. If you installed somewhere else the new install should not have a panel.xml and after sync with online designer the panel.xml should be there.

Posted by mredeker at Jul 12, 2011 08:34

I removed the current installation and reinstalled OR. After performing an online sync, I found the panel.xml file and can view the panel both via the webconsole and my Android phone. I am no longer receiving the panel.xml not found error.

Thanks for the help!

Posted by jammastercd at Jul 13, 2011 03:56
Document generated by Confluence on Jun 05, 2016 09:31