This page last changed on Feb 25, 2014 by landlingerg.

Hello,

Today i made a Controller update from 2.0.1 to 2.1.0.
It works nice but i had a problem with the sync Function.
Allways i get the error that my username and password is not correct! But i'm sure that the password and the user is correct.

Then i tryed the fix with to make a new panel in the designer and download it as zip file.
After it i get the same Error as before.

Then i opened my OpenRemote preview Designer and all panels are lost............ Fu...

I hope you can help me to get back all my panels in my Account.
Is it possible to get a backup from 25th of february before 14:00?
I have a zip File downloaded before the problem occoured.

Error Message when i try to update online:

2014-02-25 16:16:23,299 ERROR [HTTP-Thread-5]: Synchronizing controller with online account failed : Authentication failed, please check your username and password.
org.openremote.controller.exception.ConnectionException: Authentication failed, please check your username and password.
	at org.openremote.controller.service.Deployer$BeehiveConnection.downloadZip(Deployer.java:1501)
	at org.openremote.controller.service.Deployer$BeehiveConnection.access$200(Deployer.java:1394)
	at org.openremote.controller.service.Deployer.deployFromOnline(Deployer.java:543)
	at org.openremote.controller.action.ConfigManageController.syncOnline(ConfigManageController.java:140)
	at sun.reflect.GeneratedMethodAccessor38.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.springframework.web.servlet.mvc.multiaction.MultiActionController.invokeNamedMethod(MultiActionController.java:434)
	at org.springframework.web.servlet.mvc.multiaction.MultiActionController.handleRequestInternal(MultiActionController.java:372)
	at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
	at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:45)
	at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:806)
	at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:736)
	at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:396)
	at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:360)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.openremote.controller.rest.support.json.JSONCallbackFilter.doFilter(JSONCallbackFilter.java:63)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:78)
	at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:77)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:354)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:662)

With the Controller 2.0.1 it worked without any problems!

Additional Info: i compiled the "Controller_2_1_0_ProInstaller_1_0_5_20121212" svn Version from the Openremote Source Homepage!
The old Version was the Controller_2_0_1 svn Version which are also compiled from me.

regards Günther

You're compiling a Pro version of the controller, which by default will connect to the Pro server, not the free one. That might explain your authentication issue, if you don't have a Pro account (with same username/password).

For the design disappearing, make sure you always use same designer (demo, preview or staging).

Posted by ebariaux at Feb 27, 2014 11:54

Hi Eric,

Thanks for your answer! I understand!
Is there also a free version of the 2.1.0 available?
I need it for my telnet command with feedback and i read that this only is possible with the 2.1.0 version.

i only need the preview version of the designer. It could be that i unintentionally usesd the demo version and made a new panel.
After this all panels in the preview version are lost.

I do not need the backup..... I will make new panels..... it is a good training for me.

regards
Günther

Posted by landlingerg at Feb 27, 2014 13:30

There are several 2.1 versions under tags/snapshot in the SVN but not sure what functionality is in each of those.
Might go ahead and take the latest one and see if it includes the telnet command stuff you want.

Posted by ebariaux at Feb 28, 2014 11:50
Document generated by Confluence on Jun 05, 2016 09:38