This page last changed on Oct 22, 2014 by pz1.

At this moment the Pro designer service does not save edits.

Edit 10 minutes later: After a browser refresh the Save did function again. No edits lost in the macros, but the (minor) changes in UI were lost

Well I ended up loosing a complex screen after I gave a grid a different left offset. Just before I had it centred with a grid just above it.

Posted by pz1 at Oct 22, 2014 14:04

Was any error displayed in the browser ? Popup or info message in bottom right ?

I've checked the server log and there is no error reported at that time.
I see several save operations for your account around 13:30 I believe and they have all succeeded.
Around 12:30, I see save operations for another user, that were successful also.

Posted by ebariaux at Oct 22, 2014 16:26

I did not get any popup or info message at bottom right. That's why I concluded nothing was saved. Around 13:30 I did indeed quite a few save actions, because I got no feedback on my save commands. Maybe that screwed up something in my workspace.

Posted by pz1 at Oct 22, 2014 16:51

I am experience something similar.... I am changing my rules, and after doing the change the rules do not execute.
I have tried changing one of my time based rules, and only changing the "trigger" time for when the rule should execute, and nothing happens.

My original rule is as follows and is working:

rule "WAKING UP BY TURNING ON LIGHT MASTER BEDROOM"

timer (cron: 0 30-45 6 ? * 2-6)

when eval(true)

Event( source == "Status - Lys - 2 etg - Master Bedroom - Morgenlys", value == "on" )

then

execute.command("Lys - Dimming - 2 etg - Master Bedroom (UP)", 1);

end

I have change the timer settings from timer (cron: 0 30-45 6 ? * 2-6) to timer (cron: 0 30-45 17 ? * 2-6) and the lights do not turn on.
It is like the controller do not see or registered the change...

Posted by istian at Oct 22, 2014 16:53

I think the rule thing is different. A few others have reported that in the past. My cure for that was to either restart the controller, or in extreme cases restart the machine.

Posted by pz1 at Oct 22, 2014 18:05

I tried restarting the controller and even restarting the Synology box.... still no execution.
I am very curious if the rule will trigger and turn on the light tomorrow morning despite the change of time in my rule!

I have checked the rule file, and the rule is updated, but nothing happens, and there is nothing in the log that seems to be wrong...

ps alterations in my design (UI) updates and the iPhone app changes layout, so this works fine.
Other rules also works fine.

Posted by istian at Oct 22, 2014 18:31

As this is outside the scope of this topic (designer NOT saving edits), I suggest you continue in one of the rules related threads. You may get more user feedback there too.

Posted by pz1 at Oct 22, 2014 18:41
Document generated by Confluence on Jun 05, 2016 09:38