This page last changed on Jun 22, 2015 by placemaster.

From the Date / Time protocol I am using the Sunrise / Sunset option to retrieve the right values.
I use these values to switch lights on and off.
No I found out yesterday that the time retrieved is not correct. There is a difference of 2 hours.
It has worked for years.

The actual sunrise time should be 5:17 AM and sunset 22:00 PM. I do get 3:17 AM and 20:00 PM.
I have already tried to change the latitude and longitude to a different location (Singapore) to see if it changes.
There is no change. Even after restarting the controller several times it is not updating to the right value.
What can be wrong?

Update:
Finally I managed to get a result for Singapore but also there the time is incorrect with the same difference as I have at my location.
I also tried Amsterdam with the lat. and long. but same result.
My server is on UTC + 1 and this is not changed for years.


Nobody is able to answer my question?

I can not imagine that I am the only person who is using these values and were they are not correct.

Hopefully someone will answer.

Posted by placemaster at Jun 29, 2015 12:10

I did use the DateTime protocol in the past, and ran into similar problems that did not come to a solution. (I ended up moving my control logic from OR to RaZberry on Raspberry Pi.

Posted by pz1 at Jun 29, 2015 14:31

I did not notice such problems. All displayed correctly: date, time, sunrise / sunset. I compare the data with weather sites.

Posted by aleksey_z at Jun 29, 2015 14:37

That good to hear. Can you make a screenshot of your settings?
I'll try them as well and see if I do get the same result as you have.

Posted by placemaster at Jun 29, 2015 14:42
Document generated by Confluence on Jun 05, 2016 09:34