This page last changed on Mar 11, 2014 by chiorboli.

Hi all,
The new DSM v5 is out now. Does anybody know if OpenRemote is compatible with this new version? I'd like to update my 213j but I don't want to break up my OpenRemote configuration. It seems that in case of problems we can't downgrade to DSM 4.3...
Thanks

If your OR configuration is crucial, you better be patient, and wait a couple of months for a first/second update of DSM5. This time I haven't followed the beta program closely, but my impression was that this time it was a smoother ride.
I did notice that quite a bit of the extended functionality only applies to the x86 platform. For example their new Java manager.

Posted by pz1 at Mar 11, 2014 09:01

If it does not break don't fix it!

As far as I know the Java version is 7 and OR has some issues running on top of it.

Posted by aktur at Mar 11, 2014 12:48

Yes you're right, I had to downgrade from jre 7 to jre 6 in order to be able to use the OR Controller. But it should still be possible to install the jre 6 with DSM 5 no?
As Pieter suggested, I'll wait a couple of months for DSM 5 updates before thinking about upgrading my NAS...

Posted by chiorboli at Mar 11, 2014 20:17

I upgraded to DSM 5 yesterday. All is working fine with OR. I found I needed to re-install the Java version (6) using Patters method found elsewhere on here. I had hoped to use the built-in Synology JAVA manager but it seemed to only want to install JRE 7.. I didn't spend too much time with it to be honest, I just reverted back to what I knew worked for me.

Anyways, seems fine so far, no issues. Rules working etc.

Aside from OR, they upgraded their standard Database to MariaDB and changed to PHP 5.5. I had a lot of integration done in DSM 4.3 between Open Remote, MySQL the previous version of php. Took me a while to re-configure to cater for this (no fault of OR). Had I realised I would need to do this I think I wouldn't have bothered!.. And their new GUI is not very nice - in my opinion

Posted by holeymoley at Mar 12, 2014 01:02

Hi, to share my experience:
I'm using OR and the DSM 5 since it's beta version without issue.
To achieve that, I'm running on the jdk7 installed through the syno java manager but I patched the drools engine with its "java7" patch found on the net.
Yesterday, I've updated to the DSM 5 release, reinstalled jdk7u51 and it's still working fine
Regards

Posted by yannph at Mar 12, 2014 07:23

Why does it take so long before the Drools engine is updated. As said in an other thread it should be simple to do. Many new users are posed with these unnecessary Java 7 problems, and your "parch" is afaik nowhere in the indtallation instructions.

Posted by pz1 at Mar 12, 2014 07:33

Aside from OR, they upgraded their standard Database to MariaDB and changed to PHP 5.5. I had a lot of integration done in DSM 4.3 between Open Remote, MySQL the previous version of php. Took me a while to re-configure to cater for this (no fault of OR). Had I realised I would need to do this I think I wouldn't have bothered!.. And their new GUI is not very nice - in my opinion

This will probably keep me a long time before upgrading to DSM5. On Patters forum I see also that there is fighting to get CrashPlan to work correctly. I'm quite reluctant to loose all my backups and start over again.

Is there actually any real advantage of using the DSM 5? Something which is not possible in 4.3?

Posted by aktur at Mar 12, 2014 09:20

Is there actually any real advantage of using the DSM 5? Something which is not possible in 4.3

Depends on your machine. See http://www.synology.com/en-global/support/download the release note for your specific model.
It is important to keep your machine up to date. (Release 4.x was last updated on 2014-03-11. October 2013, Synology even provided a patch for my seven year old DS207+ !)

Posted by pz1 at Mar 12, 2014 09:36

I also upgraded to DSM 5 yesterday. All works fine for me although I needed to reinstall to get the controller working. Note that I have a fairly basic OpenRemote system (no rules, just KNX temp, scene, light statuses).

Posted by soyulv at Apr 08, 2014 22:02
Document generated by Confluence on Jun 05, 2016 09:39