This page last changed on Apr 20, 2014 by max.williams.

Hi All,

I have just registered and this is my first post.

I am currently attempting to install/use openremote on my Synology NAS and would like to get a little bit of help and advice if possible. I'll give a brief run down of me and what I am aiming for.

I am a intermediate computer Techy and self confessed geek. I previously installed a pre-package of openremote and gave the free designer a bash.

Now I have purchased the OpenRemote professional license and want to get the pro version of the controller installed.

Synology DS1315+
DSM 5

Packages:
Java manager
Apache Tomcat

Tomcat info:

Tomcat Version JVM Version JVM Vendor OS Name OS Version OS Architecture
Apache Tomcat/6.0.39 1.7.0_51-b13 Oracle Corporation Linux 3.2.40 i386

Install Files:
OpenRemote-Controller-Pro1.0.12 (sat on my desktop at present)

So..
I have Tomcat installed/setup and running.
I have java installed/setup and running.

Can anyone help me on what I need to do next to get this running. I would normally poke and prod around until I cracked it but I have just run out of steam and brain space. I would like to, just for once ask the right questions and get it running first time

Thanks
Max

I think this post is the most up to date.

I am not sure if that post also covers the setting of port 8688, which is typical for the Pro version

Posted by pz1 at Apr 20, 2014 13:25

Hi Pieter,

Thank you for the reply. I have already browsed through the article and unfortunately it doesn't seem to quite work out for me. What caught my eye was this:

"There is one other possible method of installing OR, without the patters package, by using the stock Synology Tomcat and Java packages. I haven't tried this myself yet, but maybe someone could do a step-by-step guide using that method?"

So I was rather hoping someone could assist with how I would go about deploying a directory and WAR on tomcat. I am going to start picking away at it and see how I get on. If I get anywhere ill update my post.

Thanks
Max

Posted by max.williams at Apr 20, 2014 16:12

What does the boot.log tell you?

Posted by pz1 at Apr 20, 2014 17:59

Hi,

Thanks for taking the time to reply and offer your help. However I really want to do this all myself, its more of a "dog with a bone" I just don't want to drop it.

Simply put I want to understand how to add OpenRemote so that If I want to move/change/update/downgrade I can do this myself instead of relying on others to do it for me. Kinda sounds stupid in a way but I just cant let it go now.

So if you or anyone else knows and can point me in the right direction, I will do the rest. If not I will find out and report back when Ive cracked it; with a full write up on how I did it of course

Thanks

Posted by max.williams at Apr 21, 2014 09:34

Hi All,

So I have got somewhere. If someone could help me figure this last bit out would be much appreciated.

Installed Java Manager
Installed Java SE 7 55
Installed Tomcat7

Edited the tomcat-users.xml and added a administrator account.

Downloaded OpenRemote Pro from online designer.
Unzipped OpenRemote Pro to /volume1/Data
Copied contents of the webapps folder to /volume1/@appstore/Tomcat7/src/webapps/

Logged onto the Tomcat app manager to check the deployments had worked

browsed to synologyip:7070/controller/
Entered in my pro username and password
Presented with below error:

The path 'file:/../webapps/controller' doesnt exist.

I would add a log file there are a few with allot of errors. So if there's one in particular let me know. I have managed to work out this its possibly a permissions issue however how I remedy this situation I don't know.

Posted by max.williams at Apr 26, 2014 10:47
Document generated by Confluence on Jun 05, 2016 09:39