This page last changed on Jan 20, 2015 by sose.

I have been using the DATETIME protocol for about two weeks. Yesterday I notices that it is no longer showing time correctly. I have the timezone set as us/mountain, but the time is +7 which indicates that the timezone is not being properly accounted for.


datetime.JPG (image/jpeg)

Just wanted to check and see if there is a fix coming for the time issue. Upon the new release, time zones are seemingly being ignored. Thank you.

Posted by sose at Jan 23, 2015 22:21

If it worked for two weeks why does it not work anymore? Did you change the timezone of the underlying OS?

Posted by mredeker at Jan 24, 2015 17:03

No, I haven't changed my NAS at all. The issue started right when 2.1 was released.

Posted by sose at Jan 24, 2015 19:34

Use of the timezone was added. You will need to add the timezone attribute to your command.

Posted by mredeker at Jan 24, 2015 22:27

I have it as:

us/mountain

in the DateTime command, but it is still +7 hours ahead of where it should be.

Posted by sose at Jan 24, 2015 22:49

Your underlying system clock might be on local time also?
Try and put that on utc or try the timezon as utc.

Posted by mredeker at Jan 24, 2015 22:54

us/mountain is GMT -7. So the fact that DateTime is showing 7 hours fast makes me have to believe it is not using the timezone I have entered. Yes, my NAS is set to local time, but if I was taking 7 hours of the local time, I would be 7 hours behind, not ahead.

Posted by sose at Jan 24, 2015 23:00

Did you try and use UTC as timezone field? Do you have 14 hours then?

Posted by mredeker at Jan 25, 2015 17:02

No, it is the same either way.

Posted by sose at Jan 25, 2015 22:03

I am seeing the same issue, I am in Eastern time zone UTC-5 and my clock is 4 hours ahead and everything I have tried has not changed the clock. My windows controller is set for eastern time zone. Has their been a fix for this?

Posted by drewscm at Apr 25, 2015 04:23

I wanted to post the solution to my time issue. I had to put the time zone in as "America/New_York", and found this website that has the proper names http://www.timezoneconverter.com/cgi-bin/zoneinfo.tzc?s=default&tz=America/New_York

Note I only tried it for america and it worked.

Posted by drewscm at May 15, 2015 17:33
Document generated by Confluence on Jun 05, 2016 09:39