This page last changed on May 11, 2015 by kcwired.

I had a run in with getting the Z-wave USB stick working. (obviously this is for windows users)

My USB bridge port came up on COM5 and I spun my wheels for a whole day. I was learning openremote for the first time as well, so i couldn't tell a hardware problem from a learning curve.
Problems eventually led me to turning on debug, but i couldn't get the debug logs to log anything. So, I had to sleep on it and worked it out the next morning.

Long story short: COM5 wasn't being seen by Open remote. (neither was COM1)

Step 1:
Where ever your USB bridge COM# may land.
In your cmd shell, Do a "MODE" command and make sure your shell can see the COM port. (I ended up on COM2)

Step 2:
Use COM# in your z-wave protocol. If open remote doesn't light up with happy console responses, or logs, contemplate a different COM port. (windows system devices advanced setting)

If you have hyper-terminal or like application that lets you send hex or whatnot to a serial port. you can fish around and test them for responses from the USB z stick com bridge. you can copy con to a port as well and send stuff, in a pinch, but you cant get responses back on console, so you have to send something that gives feed back in another way (really a modem trouble shooting hack).

Well, that was easy, in the end.

I only wish things were as simple as this....

I have been trying and trying to get an Aeon Z stick 2 working without ever succeeding. I can get it to work with other programs (Domoticz and In Control) but I never with openremote. I never get any z-wave logs within openremote except for the INFO, timestamp, version startup line. Debug settings turned on or off. It just doesn't want to work with openremote.

One thing to add to your note: Sysinternal's (sysinternals.com - which is owned by M.S.) portmon.exe is also a good tool to monitor your serial port. It can show you if you have any traffic to and from your serial port. When I use the other two programs, I see traffic to the Z stick. When I use openremote... NOTHING. I've tried the mode command and can see it. I've even changed the port to different com ports, but all with no luck. I have tried on two different systems, one 32 bit, one 64 bit. Both work with the other programs, but never with openremote. I would love to get it working so I can move into my next step in programming within openremote. I'd love to only have to use one program to control everything.

I have been through the forums again and again, trying different advice from many different people. Still no luck. I have created, deleted and re-created switches again and again.

My question to anyone with more experience with serial, java and openremote... Is Jave 1.6 really required to get this to work? I have tried 1.8, 1.7 and 1.6 all with the same results.

Posted by kslate at May 12, 2015 03:25

I'm having a similar problem with a Linux install, seeing only start up lines in the log file.

I'm planning to debug from the OS layer so was wondering if you can you tell me what baud rate the USB Z-wave stick uses and a simple HEX string I can send to get a response?

Thanks

Posted by dpstockdale at May 13, 2015 23:36
Document generated by Confluence on Jun 05, 2016 09:34