This page last changed on Dec 23, 2013 by juha.

Hi,

I first installed openremote on my Raspberry Pi, wanted to check if everything is fine by going through http://localhost:8080/controller and trying to start a synchronization. For that, I created an account directly from that page (user name stephaneberle9). As a result, I could then connect to the composer app at https://composer.openremote.org/demo. But strangely, I could still NOT login from the http://localhost:8080/controller page - I just got below mentioned Java Exception.

Also strange: even on http://www.openremote.org, my username was reported as unknown. So, I tried to recreate my account from http://www.openremote.org/ and ended up with below mentioned system error. At least, I now could log in to http://www.openremote.org/ and leave this post.

Could you please check what's wrong and arrange for that I can also login from http://localhost:8080/controller?

Thanks,

Stephan

=== Java Exception ===

ERROR 2013-12-23 01:28:50,234 : Synchronizing controller with online account failed : Authentication failed, please chec
k your username and password.
org.openremote.controller.exception.ConnectionException: Authentication failed, please check your username and password.

at org.openremote.controller.service.Deployer$BeehiveConnection.downloadZip(Deployer.java:1492)
at org.openremote.controller.service.Deployer$BeehiveConnection.access$200(Deployer.java:1385)
at org.openremote.controller.service.Deployer.deployFromOnline(Deployer.java:536)
at org.openremote.controller.action.ConfigManageController.syncOnline(ConfigManageController.java:140)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.springframework.web.servlet.mvc.multiaction.MultiActionController.invokeNamedMethod(MultiActionController
.java:434)
at org.springframework.web.servlet.mvc.multiaction.MultiActionController.handleRequestInternal(MultiActionContro
ller.java:372)
at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java
:45)
at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:806)
at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:736)
at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:396)
at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:360)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.openremote.controller.rest.support.json.JSONCallbackFilter.doFilter(JSONCallbackFilter.java:63)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:78)
at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:77)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:354)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)

=== System Error ===

System Error
A system error has occurred — our apologies!

Please ask your Confluence administrator to create a support issue on Atlassian's support system at http://support.atlassian.com with the following information:

a description of your problem and what you were doing at the time it occurred
a copy of the error and system information found below
a copy of the application logs (if possible).
Your Confluence administrator can use the support request form to create a support ticket which will include this information.

We will respond as promptly as possible.
Thank you!

Return to site homepage...

Cause
com.atlassian.core.exception.InfrastructureException: com.atlassian.user.impl.DuplicateEntityException: User [stephaneberle9] already exists in Crowd Repository
at bucket.user.DefaultUserAccessor.addUser(DefaultUserAccessor.java:102)

caused by: com.atlassian.user.impl.DuplicateEntityException: User [stephaneberle9] already exists in Crowd Repository
at com.atlassian.user.impl.delegation.DelegatingUserManager.createUser(DelegatingUserManager.java:102)

possibly unrelated but I'm running the rasperry pi openremote server on port 8688 after timeout errors on 8080. (port updated in server.xml)

Posted by rich.sperrin at Dec 23, 2013 12:46

Hello Stephan,

Make sure that on your designer account you have some initial design available (and that you can export openremote.zip out of your account). The controller currently incorrectly reports a login error if the account is empty and there's nothing to download.

HTH,

– Juha

Posted by juha at Dec 23, 2013 17:41

Thanks Juha,

this perfectly resolves the issue!

Stephan

Posted by stephaneberle9 at Dec 26, 2013 07:58
Document generated by Confluence on Jun 05, 2016 09:39