This page last changed on Aug 12, 2014 by sonitrolio.

Log says:

Caused by: org.drools.RuntimeDroolsException: value '1.7' is not a valid language level

java -version says:

java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)

I am not sure what is causing the problem. This is the NON-Pro version 2.1.0. The only thing has changed on my system recently is Windows Updates and Anti_virus update(not a new install, just virus definition updates) Has anyone else had this issue recently? My problems started Sunday night (08-10-2014)

No one has seen this problem besides me I assume.

Posted by sonitrolio at Aug 26, 2014 02:48

It looks like your start script is using a different java version then the one in your path (which is used when you do "java -version")

Posted by mredeker at Aug 27, 2014 09:23

Google isn't helping me find anything about where the start script is for openremote. I uninstalled Java, re-downloaded it and then installed again and still have the same error in the log.

Posted by sonitrolio at Aug 31, 2014 20:09
Document generated by Confluence on Jun 05, 2016 09:39