This page last changed on Apr 07, 2015 by basay.

Hi! Please, help. I can't solve the problem by myself, because the error don't give me any information.
In my OpenRemote project i have few Tab Bar items, which changes few screens in the UI. In each screens i have 4-15 switches.
If i click them often, that 7-9 seconds - the UI freezes and shows error message "The following error occurred: -Unkown Controller Error".
After cklicking OK - the UI rebooting.
The error don't appear only if change tab-bars whith big time delay.

Sorry for bad english

Hope 4 your help

Hi,

Which console are you seeing this in?

Posted by kurrazyman at Apr 07, 2015 07:48

Nothing. The controller works fine. He switching light by timer even if webconsole in uncnown error.
When I press OK - WebConsole restarting and in console I see the same info, which appears every time, when I open the console:

//----------------------------------------------------------------------------------------------------------------------------------

ERROR HTTP\-Thread\-6: failed to extract panel.xml for panel : No such Panel :NAME =
org.openremote.controller.exception.NoSuchPanelException: No such Panel :NAME =
at org.openremote.controller.service.impl.ProfileServiceImpl.getProfileDocumentByPanelName(ProfileServiceImpl.java:192)
at org.openremote.controller.service.impl.ProfileServiceImpl.getProfileByPanelName(ProfileServiceImpl.java:91)
at org.openremote.controller.rest.FindPanelByID.handleRequest(FindPanelByID.java:81)
at org.openremote.controller.rest.RESTAPI.doPost(RESTAPI.java:159)
at org.openremote.controller.rest.RESTAPI.doGet(RESTAPI.java:112)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.openremote.controller.rest.support.json.JSONCallbackFilter.doFilter(JSONCallbackFilter.java:63)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:78)
at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:77)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:354)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)
//----------------------------------------------------------------------------------------------------------------------------------

but i read in forum, that this message - not error. Here http://www.openremote.org/display/forums/Recurring+No+Such+Panel+Error

And there is no more information in console. Thats why I asking people for help.
I tried to start controller in debug mode - but it dont gave me more information. May be, i can't use debug mode? I thought, that in that mode I'll get more information in console...

Posted by basay at Apr 07, 2015 08:57

Hi Sergey,

OK so you are using the web console.

Can you email me your controller zip file and I will see if I can identify the issue.

Rich
richard[at]openremote[dot]org

Posted by kurrazyman at Apr 07, 2015 16:47

Thank you! I've send message to you.
Sorry for little disinformation - i called Web Console - UI, and it made understanding of my problem more difficult.
What else did I do to solve the trouble:
I have thought, that issue can be associated with too big information stream from the KNX network. So, in ETS I disabled almost all flags in "Read, Write, Transmit, Update..." configuration for each group. But it don't have any effect.
I can "make" that error on my home computer, which not connected for any KNX device...

Posted by basay at Apr 07, 2015 23:24
Document generated by Confluence on Jun 05, 2016 09:34