This page last changed on Oct 26, 2011 by mbarne36.

Hello.

I need some help i'm afraid.

Simple request.... I want my OpenRemote Controller to be able to Wake Up a PC that I am trying to control with MCE Controller.

So... I have A TCP Socket running on a PC accepting commands to control MediaPortal - this is a PC running MCE Controller.
I have another PC which is my OpenRemote Controller which is accepting commands from my Tablet.

I want to allow the tablet to tell the Controller to wake up the Mediaportal PC.

This should be easy right, with the WOL Protocol? I entered the MAC Address of the Mediaportal PC and the IP Address for Broadcast, but when I press my magic button on the tablet, I get the error "Command Builder not Found".

Has anyone got WOL working?

cheers guys

I haven't integrated the WOL into the release branches yet – you'll likely need to pull one of Marcus' dev branches of controller to use it. I'm gonna leave it to Marcus to point you to a branch he considers stable enough to test.

Posted by juha at Oct 27, 2011 15:54

UDP Send command could do the job provided the correct packet structure is used although I haven't tried this myself.

Posted by kurrazyman at Oct 27, 2011 19:50

Martyn,

WOL protocol is available in the designer but as Juha said not in the controller download yet.
You can try and use this dev branch: https://openremote.svn.sourceforge.net/svnroot/openremote/workspace/mredeker/Controller_2_0_0_Alphas

Otherwise I can also provide you a controller.war that includes the WOL protocol.

--Marcus

Posted by mredeker at Oct 27, 2011 20:43

Thanks Marcus.... i'll try this at the weekend.

Do i have to build/compile this? if so, can you point me at a forum or turotial?

thanks

Posted by mbarne36 at Oct 28, 2011 12:16

Yes, you have to build.
Maybe i can just send you ready .war file (it's about 7MB)

Posted by mredeker at Oct 28, 2011 12:20

that would be great if you can......

Can you get my email address through the forum, or should I post it here?

cheers.

Posted by mbarne36 at Oct 28, 2011 12:28

Just send me an email to: marcus (at) openremote (dot) org

Posted by mredeker at Oct 28, 2011 12:41

Hi Marcus

No luck for me - I suspect teething problems at my end. Please help.

So I got the WAR file, and I have put it into the WebApps folder - didn't work. I put it in the library folder (WEB-INF/lib/native) - didn't work. I put it in the bin folder - didn't work.

Each time I relocated it, I restarted the OpenRemote script.

I can't work out where I'm supposed to put it.... (no funny answers).

Was there supposed to be a previous controller.war to overwrite? If so, I couldn't find it...

So sorry if I being thick.... So I still get Command Builder not found, and the console window says "Cannot Find wolBuilder".

thanks in advance....

Posted by mbarne36 at Nov 01, 2011 09:20

It has to go into webapps folder. It might be the case that the webapps folder as an extracted .war file where it's only the subfolder "controller". You will have to delete the "controller" folder from webapps then copy controller.war to webapps and restart.

Posted by mredeker at Nov 01, 2011 10:20

Bingo Marcus thanks very much .

So no errors or complaints now, but I can't (yet) determine if it actually works because if I disable the "Only allow a magic packet to wake this computer", the damn think wakes up every time it goes to sleep (or 1-2 seconds afterwards). I have to find out what else is waking the PC up and stop it. Perhaps a network analyser.

It's a shame that the OpenRemote WOL packet doesn't support magic packet (??)

Posted by mbarne36 at Nov 01, 2011 13:53

The OpenRemote WOL implementation sends a so called "magic packet".
You should try without OpenRemote first to setup the computer you want to wake-up, correctly.
I also had trouble setting up Linux computer correctly, so I could test.
There are a few free windows tools which you can use to test.

Posted by mredeker at Nov 01, 2011 14:09
Document generated by Confluence on Jun 05, 2016 09:32