This page last changed on Apr 16, 2013 by mb.

Hi Richard

The label sensor status text in my webconsole panel does not appear; look at this image:

Look at the iPad panel:

Thanks fo any suggestions.


webconsole 01.JPG (image/jpeg)
webconsole 01.JPG (image/jpeg)
webconsole 01.JPG (image/jpeg)
webconsole 00.JPG (image/jpeg)
webconsole 01.JPG (image/jpeg)
ThermostatMode.png (image/png)
sensorstates.JPG (image/jpeg)
lightoff.JPG (image/jpeg)
lighton.JPG (image/jpeg)
webconsole landscape.JPG (image/jpeg)
webconsole landscape2.JPG (image/jpeg)
webconsole portrait.JPG (image/jpeg)

Same here. iPhone panel shows defined label text for sensors, webconsole only on/off (irrespective of defined sensor on/off text).

Posted by dgltx at Jul 06, 2013 04:17

This seems to be an unresolved issue tracked at WEBCONSOLE-57

Posted by juha at Jul 10, 2013 18:16

Can you please try this updated webconsole by replacing the webconsole.war in your webapps folder with the one from the link below; unfortunately I haven't tested the changes so please let me know if it fixes the issue: -

https://www.dropbox.com/s/0xghxxl2cq2twkk/webconsole.war

Rich

Posted by kurrazyman at Jul 11, 2013 18:59

Hi Richard,

Just tried the new webconsole. I get the info screen showing that I have the new version which is not complete, security missing.
After clearing the cache and loading the controller I have still the same issue that defined labe text for sensors are shown only as on/off.
Sorry to have no better news.
Dennis

Posted by dgltx at Jul 12, 2013 03:35

Does not seem to work for me either. What is the version number of this new release? The one I placed on my Synology still has the number 7746.

I use the mappings shown in the image

Posted by pz1 at Jul 12, 2013 09:43

Should be version 8895 and I have just verified that the fix works ok for me: -

Panel then shows the following: -

Please try Ctrl+Shift+R hard refresh of your browser.

Rich

Posted by kurrazyman at Jul 13, 2013 10:43

Apparantly we done the same thing at about the same time. I reinstalled. Works fine for me now to. Indeed I have 8895.
I don't know what I have doen wrong in the firast round. Now I stopped ORC, deleted directory webconsole, replaced webconsole, restarted ORC.
Sorry for the confusion.

Posted by pz1 at Jul 13, 2013 10:54

No problem Pieter, glad to hear it is working!

Rich

Posted by kurrazyman at Jul 13, 2013 10:56

Hi everybody

Now with the build 8895 works for me, but I have an error rotating in portrait, look at this images:


Thanks for any suggestions

Posted by mb at Jul 16, 2013 09:59

-> "Unknown Controller Error" – there's probably something in the logs with a stack trace that gives more detail why it failed, any ERROR messages popping up on controller console output (when started with 'openremote run') when this message pops up on web console?

Posted by juha at Jul 16, 2013 10:39

Hi Juha,
On "webconsole" in landscape:
1) I started the webconsole in landscape: OK it start
2) When I click the button "ROTATE", the webconsole show me the error that You can see in my last imaages (Unknown Controller Error)

On "webconsole" in portrait:
1) If I try to load the panel in portrait mode, it show me the error,
2) if I ROTATE in landscape it works.

Seems not depend on the button ROTATE but in something when loading in the portrait mode...

i hope you understand my issue or better what i wrote

Thanks

Posted by mb at Jul 18, 2013 10:30

Hi Maurizio,

The (Unknown Controller Error) is not telling much about the root cause, are the any errors on the controller side logs when this error pops up in your webconsole?

Posted by juha at Jul 18, 2013 10:36

Please Juha,
this is my logs directory:
mbso@mbso-htpc:~/Desktop/OR210/logs$ ls
boot.log container dev isy99 knx lagarto onewire

where can I find the webconsole log ?

Thanks

Posted by mb at Jul 18, 2013 10:47

Can you do

> grep ERROR ../logs/dev/dev.log |less

Or: zip the logs directory and email it to me

Posted by juha at Jul 18, 2013 11:06

Hi Juha,
look at my code:

mbso@mbso-htpc:~/Desktop/OR210/logs/dev$ ls -l                             
total 5944                                                                 
-rw-rw-r-- 1 mbso mbso 378561 Jul 18 13:49 dev.log                         
-rw-rw-r-- 1 mbso mbso 512147 Jul 18 13:49 dev.log.1                       
-rw-rw-r-- 1 mbso mbso 512044 Jul 18 13:47 dev.log.10                      
-rw-rw-r-- 1 mbso mbso 512070 Jul 18 13:49 dev.log.2                       
-rw-rw-r-- 1 mbso mbso 512117 Jul 18 13:49 dev.log.3                       
-rw-rw-r-- 1 mbso mbso 512124 Jul 18 13:48 dev.log.4                       
-rw-rw-r-- 1 mbso mbso 512115 Jul 18 13:48 dev.log.5                       
-rw-rw-r-- 1 mbso mbso 512063 Jul 18 13:48 dev.log.6                       
-rw-rw-r-- 1 mbso mbso 512116 Jul 18 13:48 dev.log.7                       
-rw-rw-r-- 1 mbso mbso 512030 Jul 18 13:48 dev.log.8                       
-rw-rw-r-- 1 mbso mbso 512119 Jul 18 13:47 dev.log.9                       
-rw-rw-r-- 1 mbso mbso 470496 Jul 18 13:49 sensors.log                     
-rw-rw-r-- 1 mbso mbso  67961 Jul 16 10:09 xml-parser.log                  
mbso@mbso-htpc:~/Desktop/OR210/logs/dev$ grep ERROR dev.log | less  
(END)       
mbso@mbso-htpc:~/Desktop/OR210/logs/dev$ grep error dev.log | less         
(END)
mbso@mbso-htpc:~/Desktop/OR210/logs/dev$                                   

Is my code right ?
I can't finde any error

Thanks for any suggestions.

Posted by mb at Jul 18, 2013 12:51

Hi Maurizio,

Your grep output would indicate that there are no errors in the dev log. If the error is occuring when you are rotating the web console into portrait then that would indicate that there is a problem with the screen definition can you please email me your controller.zip to richard[at]openremote[dot]org. I am away for the next week or so but will try and have a look and see if there is anything obvious.

Rich

Posted by kurrazyman at Jul 18, 2013 17:40
Document generated by Confluence on Jun 05, 2016 09:32