This page last changed on Jul 03, 2013 by nejc.

Hi guys.

I've been absent for a while from this project, so I need some advice please. Once again, I would like to run the Designer locally, so I would like to know which is currently the most reliable and bugs free version of the Designer and the Beehive. I would like to have web view in the Designer, so as I knew, it should be 2.14 or higher. Of cores I ask for the open Designer, not for the ProDesigner.

Thanks for the advice!

Regard,
Nejc

Your best bet may be http://svn.code.sf.net/p/openremote/code/workspace/juha/Designer_2_14_0_Preview-MODELER-453-413-470-416-448-456-435/

Even if that is still missing several patches from Eric I still plan to add sometime this month.

Stable Beehive remains at http://svn.code.sf.net/p/openremote/code/tags/project/Beehive/Beehive_3_0_0_Beta1/

Posted by juha at Jul 03, 2013 09:21

This was a quick response. Thanks Juha!

I looked in the config.propertis file and I found an unfamiliar line: "irService.REST.Root.Url = http://localhost:8080/irservice/rest/". It is probably related to the LIRC. Am I right?

And I forgot to ask for the latest version of the Controller.

Juha thanks again.

Nejc

Posted by nejc at Jul 03, 2013 10:03

I have started Beehive + msql and Designer on Apache Tomcat 6.0.18 (http://svn.code.sf.net/p/openremote/code/attic/trunk/Runtime/).
All goes well. I created account and tied to create some commands and panels. I created commands and saved it, but when I created a panel and tried to save it, the error 500 accrued. Any suggestion to solve this problem?

Posted by nejc at Jul 03, 2013 12:25

The stack trace after the error 500 will give a clue.

Chances are there's something amiss in the config.properties file.

Posted by juha at Jul 03, 2013 12:51

The problem is solved!

I've found the right solution at: http://www.openremote.org/display/forums/OpenRemote+to+control+Siemens+PLC+-+500+error+when+saving+design.

As Jente Libars said: Update: used wrong GWT to build designer.

It is crucial to use GWT 2.4.0 and not GWT 2.5.1.

Posted by nejc at Jul 03, 2013 14:44

That's strange, I'be compiled the designer with GWT 2.5.0 and 2.5.1 on my dev machine with issues.
I'll do some tests again to see if I'm not mistaken.

Posted by ebariaux at Jul 04, 2013 13:16
Document generated by Confluence on Jun 05, 2016 09:32