This page last changed on Sep 14, 2014 by gadgetguy.

Good afternoon all! Hopefully someone can help me out with this configuration issue. My end goal is to be able to use OR with my X10 CM15A device.

First, some background: OR has been configured on under Ubuntu 14 following the instructions on openremote.org. I can successfully get the server started within Terminal. I have designed an interface with OpenRemote Designer with a couple of X10 devices in my home for testing purposes. I have installed mochad so the CM15A will interface with the computer and OR. Using

cd ~/Downloads/mochad
sudo ./mochad
nc localhost 1099
pl b3 on

I am able to get a light to turn on. However, as soon as I use the OR app on my iPhone to attempt to turn on B3, Terminal spits out:

Experimental: JNI_OnLoad called.
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.1-7
ERROR HTTP\-Thread\-1: com.jpeterson.x10.GatewayException: Requested com port /dev/ttyS0 does not exist.

I've tried going in to webapps/controller/WEB-INF/classes/config.properties and changing com.port= to the USB device ID I found to be the X10 device through lsusb, which happens to be Bus 003 Device 006. I've tried a variety of formats for this, including com.port=003,006 and com.port=003 - perhaps I don't have the correct format for a USB devices?

I've googled what I can think is nearly every possible answer to get my solution and still can't figure it out. I'm sorry if this has already been covered somewhere but I certainly cannot find it! Thanks in advance.

Joel,
It seems like you've got two things going on.
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.1-7
which implies that the OS (ubuntu) has an older version of RXTX installed (2.1.7) and OR is using and expecting 2.2pre1. This may or may not matter.

With regards to the error for the com port I suspect that you may have created a device command in OR to use X10 protocol which is for the CM11A (serial port interface). As you probably know the CM15A uses USB.

mochad provides the interface to the CM15A using the TCP/IP protocol.
Commands can be sent to devices to the CM15A through mochad by creating a Device Command as follows:
Name: Turn On Light
Protocol: TCP/IP
IP Address: 127.0.0.1
Port: 1099
Command: rf b5 on

I too have been trying to get OR to interface with the CM15A but my focus has been to listen to the incoming signals received by the CM15A using the UDP Listener so I can have sensors trigger rules. Here is a link to my posting in the thread http://www.openremote.org/display/forums/UDP+Listener+Questions?focusedCommentId=22888128#comment-22888128

References that you probably read: http://openremote.org/display/docs/OpenRemote+2.0+How+To+-+X10+Devices

I hope this helps.

Posted by devodl at Sep 24, 2014 03:03

Thank you so much Steve! I knew it was something so simple that I was just glossing over. I did read that page but the links to the details lead to mochad's project page on Sourceforge that gives precisely zero details, as far as I could find. Again, thank you.

Posted by gadgetguy at Sep 28, 2014 01:48
Document generated by Confluence on Jun 05, 2016 09:39