This page last changed on Apr 07, 2015 by kslate.

What needs to be configured to get Openremote to work with a vera lite controller to control a z-wave light switch? I configured the vera section under Config for Controller but does the z-wave portion also need to be filled out as well? If so, what needs to be selected? Can Openremote control a z-wave device through the vera lite?

I created a command and selected the Vera protocol. Picked ON for one command and OFF for another. I also added the ID number of the z-wave device. I then created two buttons that use those two commands. When I hit either one, I get a "command not found" error.

Probably doing something wrong but I'm not sure what. Can anyone point me in the right direction?


Controller screen.PNG (image/png)
Controller screen AG.PNG (image/png)
zwave1.png (image/png)
zwave2.png (image/png)
zwave3.png (image/png)

So... does anyone know if you can use a Veralite to control z-wave devices through Openremote? All the docs point at having an Aeon Z-stick 2 but if that is the case what is the point of the Vera configuration connection in the designer? What does this connection get you?

I'm aware that the professional designer allows for easier z-wave integration, but is this limited to using a Aeon Z-stick only? Do you have to use the z-wave 2 jar file in the free designer? Is it even possible with a Veralite to control z-wave devices? I purchased the Veralite in hopes of expanding my Openremote ability control other things such as z-wave or insteon but was that a bad choice?

I'd like to start doing some z-wave design but I'd prefer to do this in Openremote. The Vera interface is painfully bad in comparison to what you can come up with within Openremote.

Has anyone successfully done this with a Veralite? Or done any integration with one?

Posted by kslate at Apr 10, 2015 00:07

Hi Kevin. Yes Openremote is able to control z-wave devices.

Actually we prefer let the z-wave network to vera and the interface is handled by openremote.

I think this can help you.

http://openremote.org/display/docs/OpenRemote+2.0+How+To+-+Micasaverde+Vera

For better performance avoid veralite UI7. Everything work better with the UI5.

Posted by edito at Apr 17, 2015 00:05

After a lot of trial and error, I gave up on the Veralite box and returned it. I was very unimpressed with it's user interface (UI7). It was clunky and very frustrating to use. The interface(s) I've created with Openremote far exceed anything I found on the Vera box. I have a couple of Globalcache IR boxes that I've got working to my liking. The Vera interface was terrible in comparison. I control my Tivo via Openremot and it is great. The Vera's Tivo add on was REALLY BAD. It even caused my Tivo to spontaneously reboot several times (it's stopped after I removed the app).

I also was getting nowhere trying to get Openremote to use the vera for z-wave control so ended up picking up a Aeon Z Stick 2. Unfortunately I'm not having a lot of luck with it either. I've tried the Z stick with a couple of other Home automation software packages and it works fine with them. I can control my z-wave light dimmer switch with a few of these other software platforms... Just not in Openremote. I did get the dimmer working with the Vera as well, but the interface was not great. Pretty frustrating. I've followed every set of instructions / forum posts I could fine but still no go. (And yes, I do shut down the other programs before trying to get things working on Openremote.)

Nothing logs into my z-wave log files at all. No matter what I do. Each time I restart Openremote I get a single line:

INFO 2015-04-15 23:01:36,141 (Z-Wave):

--------------------------------------------------------------------

OpenRemote Z-Wave protocol version : '2.0.0'

--------------------------------------------------------------------

But nothing else ever logs. I've downloaded the updated zwave jar file. I've changed the logging level to DEBUG (log4j.properties). I've configured the Z stick in the configuration section of the designer. I've followed the instructions for z-wave version 2 and created an include and exclude switch (I never get a nodeID.xml file). I've even tried things on an entirely different computer. Still things don't log at all. Not sure what I'm missing but very frustrating. I have other log files that are logging, but I don't find anything in them to point to why the z-wave setup is not working.

I would really like to incorporate z-wave light control into my setup but I'm not getting anywhere.

Posted by kslate at Apr 21, 2015 01:07

Sounds very similar to my initial issues here :

http://www.openremote.org/display/forums/Trouble+with+Z+Wave+addition+Aeon+Labs+Zstick+2E?focusedCommentId=22889243#comment-22889243

Is your machine running a 64bit operating system?

Posted by niedejb at Apr 21, 2015 12:03

Hi Kevin.

As i can see you Z-stick is fine.

Have you assigned the right com port in designer. Double check you configuration in controller. zwave.pad.port: 7876

zwave.commLayer: rxtx

you will need three commands in order to make it works off, on and status.
Also create a switch and a sensor.
All this have to be done in building modeler

After that go to ui designer tab and tie each command to the images in you desing.

And. SAVE.

the final step is sync you local controller with the content that you have in designer.

When you be testing with you mobile device (android/ios). look at the blue light of the stick it should be blinking every time you press the button in you interface.

also keep an eye and check if any error pop up in you local controller.

A question for you. Do you see any error when you controller deploy or in

openremote-controller > logs > zwave ?

Just in case you can get success post an image of you controller and zwave log file.

happy testing.

Posted by edito at Apr 21, 2015 15:44

My original server is a 32 bit OS. When that did not work, I also tried it on a 64 bit OS but did not see/find any rxtxserial.dll errors in any of the logs. I also double checked the settings and the com port is set correctly as is the rest of the configuration portion. I have an ON OFF and Status command configured with a sensor and a switch. Still does not work. No logs within the zwave/zwave.log files at all. Except for the protocol version listed above.

So after a lot more trial and error... I have at least figured out that Openremote is NOT talking to the serial port at all. I ran a serial port monitor program and I get nothing at all when Openremote is running. There is not data going to and from the serial port at all. I then installed Domoticz and can watch it query the Z stick and I can see my zwave lamp module with it, AND the Serial monitor program shows the traiffc to and from the Z stick.

Any thoughts on how to trouble shoot the serial port through Openremote?

Posted by kslate at Apr 22, 2015 01:19

can you post something like this

Posted by edito at Apr 22, 2015 03:08

There does seem to be an issue with my sensor but would that be enough to cause nothing to be sent to the serial port?

--------------------------------------------------------------------

  DEPLOYING NEW CONTROLLER RUNTIME...

--------------------------------------------------------------------

INFO 2015-04-21 21:38:37,231 : No rule definitions found in 'c:\openremote\webapps\controller\rules'.
INFO 2015-04-21 21:38:37,231 : Initialized event processor : Drools Rule Engine
INFO 2015-04-21 21:38:37,250 : Initialized event processor : RRD4J Data Logger
INFO 2015-04-21 21:38:37,250 : Initialized event processor : EmonCMS Data Logger
ERROR 2015-04-21 21:38:37,452 : Creating sensor failed. Error : org/openremote/controller/ZWaveConfiguration 
 XML Element : <sensor xmlns="http://www.openremote.org" id="106973171" name="TV Room Light" type="switch">
      <include type="command" ref="4729" />
      <state name="on" />
      <state name="off" />
    </sensor>
java.lang.NoClassDefFoundError: org/openremote/controller/ZWaveConfiguration
	at org.openremote.controller.protocol.zwave.DefaultZWaveConfigurationManager.createZWavePortConfiguration(DefaultZWaveConfigurationManager.java:74)
	at org.openremote.controller.protocol.zwave.DefaultZWaveConfigurationManager.getPortConfiguration(DefaultZWaveConfigurationManager.java:47)
	at org.openremote.controller.protocol.zwave.ZWaveCommandBuilder.initZWaveController(ZWaveCommandBuilder.java:245)
	at org.openremote.controller.protocol.zwave.ZWaveCommandBuilder.build(ZWaveCommandBuilder.java:145)
	at org.openremote.controller.command.CommandFactory.getCommand(CommandFactory.java:164)
	at org.openremote.controller.model.xml.Version20SensorBuilder.parseSensorEventProducer(Version20SensorBuilder.java:420)
	at org.openremote.controller.model.xml.Version20SensorBuilder.build(Version20SensorBuilder.java:287)
	at org.openremote.controller.deployer.Version20ModelBuilder.buildSensorObjectModelFromXML(Version20ModelBuilder.java:817)
	at org.openremote.controller.deployer.Version20ModelBuilder.buildSensorModel(Version20ModelBuilder.java:663)
	at org.openremote.controller.deployer.Version20ModelBuilder.build(Version20ModelBuilder.java:557)
	at org.openremote.controller.deployer.AbstractModelBuilder.buildModel(AbstractModelBuilder.java:154)
	at org.openremote.controller.service.Deployer.startup(Deployer.java:858)
	at org.openremote.controller.service.Deployer.softRestart(Deployer.java:440)
	at org.openremote.controller.service.Deployer$ControllerDefinitionWatch.run(Deployer.java:1324)
	at java.lang.Thread.run(Unknown Source)
INFO 2015-04-21 21:38:37,575 : Registered sensor : Sensor (Name = 'Status Contact 3', ID = '106905250', State Mappings: {state,1:3,0=OFF, state,1:3,1=ON})
INFO 2015-04-21 21:38:37,575 : Registered sensor : Sensor (Name = 'Status Contact 2', ID = '106905249', State Mappings: {state,1:2,1=ON, state,1:2,0=OFF})
INFO 2015-04-21 21:38:37,575 : Registered sensor : Sensor (Name = 'Status Contact 1', ID = '106905248', State Mappings: {state,1:1,1=ON, state,1:1,0=OFF})
INFO 2015-04-21 21:38:37,586 : Startup complete.
Posted by kslate at Apr 22, 2015 03:22

ok now we know how proceed.

you right there is a problem with you sensor.

Recheck you building modeler, take a look to you zwave log files

and post again you controller screen but the lines that show you java version.

Posted by edito at Apr 22, 2015 03:56

Main parts from stdout log:

2015-04-21 21:38:14 Commons Daemon procrun stderr initialized
21-Apr-2015 21:38:15.045 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server version:        Apache Tomcat/8.0.20
21-Apr-2015 21:38:15.047 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server built:          Feb 15 2015 18:10:42 UTC
21-Apr-2015 21:38:15.047 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server number:         8.0.20.0
21-Apr-2015 21:38:15.047 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log OS Name:               Windows Server 2008
21-Apr-2015 21:38:15.048 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log OS Version:            6.0
21-Apr-2015 21:38:15.048 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Architecture:          x86
21-Apr-2015 21:38:15.048 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Java Home:             C:\Program Files\Java\jre7
21-Apr-2015 21:38:15.048 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log JVM Version:           1.7.0_75-b13
21-Apr-2015 21:38:15.048 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log JVM Vendor:            Oracle Corporation
21-Apr-2015 21:38:15.048 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log CATALINA_BASE:         C:\openremote
21-Apr-2015 21:38:15.049 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log CATALINA_HOME:         C:\openremote
Posted by kslate at Apr 22, 2015 04:08

As i can see you have java 7

For my was a headache until i changed to java 1.6.0.18

to confirm type c:\java -version and hit enter.

In order to make openremote you need to set Java environment.

After that restart conrtroller and sync with designer.

Posted by edito at Apr 22, 2015 04:20

I am planning to migrate from my currently working x10/OR setup to zwave. Gradually.
The above question is exactly mine:

Zwave via z-stick, or zwave via vera.

Edito says: "Actually we prefer let the z-wave network to vera and the interface is handled by openremote." Is this OR's advice?

Native OR support of the z-stick comes with a 10 unit zwave limit; not a real showstopper but a note.

Vera blogs indicate lots of issues; as opposed to OR general blogs indicating lots of capability.

My experience with OR is great. Even using x10 via mochad.

But, if/when the cm15A dies, Insteon seems to be able to handle x10, and Vera can handle Insteon. One could still use one's x10 modules.
At a minimum $50/module for zwave, or anything else, squeezing life out of x10 modules is usually worth it.

It seems like Vera has some nice capabilities, but significant drawbacks.

Can this community weigh in on this question. Given the popularity of x10, there has to be a (z)wave of migration coming.

z-stick or Vera.

Posted by scruise at Oct 19, 2015 22:49

Further research indicates that RaZberry is a decent path.

Perhaps the forum is trying to tell me this ....

Posted by scruise at Oct 22, 2015 00:25

Hi Stan.

I have tested both. I ended with the Z-stick. Why? The Z-stick propagate status change of the light faster than the vera light. For example, when turn on the light in the wall switch

you can see immediately the status change in the tablet or mobile phone. With vera this can take 1,2 or 3 seconds. And there is not reason for that because the switch support stauts report

Vera is a versatile device but a little bit slow for me.

About the Raspberry Pi, for me is a little bit slow. In my scenario the machine that run openremote controller also acts as media player (Kodi actually), Maybe when the Raspberry Pi 3 see

the light depending of the spec i'll give it a opportunity.

If you choose vera keep in maind this, if vera lost the network connection for a while you have to restart openremote controller to re establish the communication with vera. Learned in the hard way...

Posted by edito at Oct 22, 2015 23:36
Document generated by Confluence on Jun 05, 2016 09:34