This page last changed on May 23, 2014 by stimien.

Hi,

I have a synology ds410 with the MPC8533E PPC processor.
I am trying to get OpenRemote working on this system. I followed this tutorial:http://www.openremote.org/display/docs/OpenRemote+2.0+How+To+-+Synology+with+Z-Wave
But while i was busy i noticed that the rxtx library mentioned isn;t gonna work for the ds410 because of the processor.
I tried it anyway and get the following stacktrace:

Java HotSpot(TM) Embedded Client VM warning: You have loaded library /volume2/@appstore/OpenRemote/webapps/controller/WEB-INF/lib/native/librxtxSerial-2.1-7.so which might have disabled stack guard. The VM will try to fix the stack guard
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
java.lang.UnsatisfiedLinkError: /volume2/@appstore/OpenRemote/webapps/controller/WEB-INF/lib/native/librxtxSerial-2.1-7.so: /volume2/@appstore/OpenRemote/webapps/controller/WEB-INF/lib/native/librxtxSerial-2.1-7.so: ELF file data encodin
Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /volume2/@appstore/OpenRemote/webapps/controller/WEB-INF/lib/native/librxtxSerial-2.1-7.so: /volume2/@appstore/OpenRemote/webapps/controller/WEB-INF/lib/native/librxtxSerial-
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1880)
at java.lang.Runtime.loadLibrary0(Runtime.java:849)
at java.lang.System.loadLibrary(System.java:1088)
at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:123)
at org.openremote.controller.protocol.zwave.ZWaveGatewayRxtx$ZWaveConnectionThread.run(ZWaveGatewayRxtx.java:108)
INFO 2014-05-21 21:57:50,285 : No rule definitions found in '/volume2/@appstore/OpenRemote/webapps/controller/rules'.

Can you help me with this problem. Maybe someone has the librxtxSerial-2.1-7.so library for MPC8533E or is there someone that can explain to me with a detailed howto on how to create the librxtxSerial-2.1-7.so for my processor?

Thanks for reading and hopefully helping.

Hi there,

did you make any progress on this issue, i am experiencing the same problem. tried several libserial files in conbination with java 7 and java 8.
Unfortunately i got the same message.
also the Catalina.out is not being generated. Im hoping that it can be solved with the libsxtxserial file.

im stil far away from a working config becouse i do not have a aeon labs zwave stick but a eminent zwave stick and i am not 100% sure that the drivers are correctly installed.

Posted by bart groot at Feb 04, 2015 06:38

Hi,
Any progress on that problem I have DS413 and i have tha same issue. Can someone help me?¨

Thanks David

Posted by abelovsky at Feb 19, 2015 00:29

Hi,

i didn't try to fix this any longer. Because their was only support for 10(or maybe 20) devices in the free version.
My solution was: buy raspberry and switch to domoticz.

Cheers

Posted by stimien at Feb 19, 2015 07:13

Because their was only support for 10(or maybe 20) devices in the free version

The new Z-Wave implementation allows an unlimited number of devices in the free version too.

Posted by pz1 at Feb 19, 2015 09:35

This new Z-Wave implementation was the reason to start with OpenRemote. I was going to install OpenRemote on my Nas but this is stil not working.
To get started i bought a used dell FX170 thin client (€25,00) installed Slitaz Linux and OpenRemote. Not my ideal solution but good enough for me.

Posted by bart groot at Feb 19, 2015 12:51
Document generated by Confluence on Jun 05, 2016 09:39